• Resolved Amelia Rose

    (@shawnrisk)


    Each time I try to Test Mail in the tools tab of the settings and check Don’t wait for cronjob, I get an error saying Error sending mail. I’m using iPage as host and entered in all the details including using SSL. If I leave the settings blank, the whole website goes offline as the queue limit is hit really fast.

    I could up the limit on advanced settings page but unsure what they should be? This was working before but maybe the influx came in once a newsletter was sent out.

    Currently here are the settngs:
    Queue Limit: 8
    wp_cron interval: 900
    Min. recipients to enqueue: 1
    Max. retry for mail sending: 0
    Sent mail storage size: 0

    • This topic was modified 2 years, 8 months ago by Amelia Rose.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Birmania

    (@birmania)

    Hi @shawnrisk,

    When SMTP settings are blank, plugin fallback on values defined through wp action/filters and default WordPress settings. These default values may not be sufficient for mail sending in your case.

    “Queue Limit” is an historical name but this property means : “How much mails should be processed per run/batch”. You are processing 8 mail every 15 minutes. According to these values, you may change them to avoid burst and get similar throughput by reducing both “wp_cron interval” and “Queue Limit”.
    New values could be :
    Queue Limit : 1
    wp_cron interval : 120

    As far as I can read, it seems that your main problem is linked to your SMTP settings because test mail should not throw an error. Let’s try to solve this !

    Firstly, you can download the new 1.4.5 version I just uploaded. I added a notice with more details on the error you encounter when sending immediate test mail.

    Secondly, you can try to switch from ‘SSL’ to ‘TLS’ as SMTP server are less and less supporting the ‘SSL’ protocol.

    Thirdly, you can test with another SMTP provider to detect if the problem come from your website configuration (eg. installed plugins) or from SMTP settings.
    In order to do this, please create a free sandbox on ‘https://mailtrap.io/’ and try to send a test mail to their service.

    On my side, I made it working with mailtrap using :
    Mode : ‘TLS’
    Host: smtp.mailtrap.io
    Port: 2525
    Use auth : True
    Username: *look-in-your-inbox-credentials*
    Password: *look-in-your-inbox-credentials*

    Yours faithfully,
    Birmania

    Thread Starter Amelia Rose

    (@shawnrisk)

    Thanks. I have followed the steps and here is the outcome.

    The send test email tool says this error: Error detail while sending mail : ‘The following From address failed: : MAIL FROM command failed,SMTP Envelope Sender must be valid ,550,SMTP server error: MAIL FROM command failed Detail: SMTP Envelope Sender must be valid SMTP code: 550’. Do I need to add a From Name and From Email in the SMTP Settings?

    I will try the mailtrap sandbox if nothing else works.

    Plugin Author Birmania

    (@birmania)

    Nice. Indeed, it seems that mails are not sent due to invalid “From” field.
    Default WordPress values for ‘From’ and ‘From Email’ are ‘WordPress’ and ‘wordpress@yoursitename’.

    These values may create some problem, especialy if you are working on ‘localhost’ which is not a valid site name.

    Can you try to set a From name/mail in settings and re-test the mail sending ?

    Thread Starter Amelia Rose

    (@shawnrisk)

    I have put in the the needed text for the From and From Email. This actually made the test email this work.

    I’m working on a domain not localhost.

    Since this is a problem, would you be able to make sure that the plugin checks which fields are needed and add in what the no text/default will mean?

    Plugin Author Birmania

    (@birmania)

    It is very hard to detect which value will be set when sending email as it can be modified by multiple filter/plugin registered.

    In future version, I wil add some information about WordPress behavior when you do not fill these fields as some other plugins do :


    • This reply was modified 2 years, 8 months ago by Birmania.
    • This reply was modified 2 years, 8 months ago by Birmania.
    Thread Starter Amelia Rose

    (@shawnrisk)

    Thanks, this is very useful.

    I’m using ninja forms. I want the thank you email to be sent by the domain email and the emails going to the targets of the forms from the signers. Will that still be possible?

    Plugin Author Birmania

    (@birmania)

    Hi back @shawnrisk,

    In fact, I do not recommend sending mails with a “From” value which is not under your control (eg : e-mail of the signer). SMTP servers will not be able to detect your sending server as an authorized one for this domain (See ‘SPF’ and ‘DKIM’) and it will immediately fall in SPAM folder.

    However, you can clearly add the email of the signer in the “Reply-To” field which is a good practice as the receiver will be able to reply to the signer without any domain impersonation.

    Same question as your here : https://wordpress.org/support/topic/change-the-sender-of-the-email-2/

    How to add user email in “Reply-To” field in Ninja form :
    https://ninjaforms.com/docs/email/

    Hope that it can fulfill your need.

    Yours faithfully,
    Birmania

    Thread Starter Amelia Rose

    (@shawnrisk)

    The people who made the form said they think your solution will work. If they change their mind, I will make sure to get back in touch.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Send Test Mail Error sending mail’ is closed to new replies.