Support » Plugin: bbPress Messages » Send Messages are not working

  • Resolved brianperera

    (@brianperera)


    Hi,

    I installed the bbpress message plugin but when I try to send a message nothing happens.

    Steps:
    1. New Message
    2. Search contact -> select recipient
    3. Type message -> Send

    The message does not get send. Im just presented with a message saying There are no chats to show. I checked the following table after sending the message and its also empty.
    * wp_bbp_messages_2p0

    The log file has the following warning,
    PHP Warning: preg_match(): Compilation failed: escape sequence is invalid in character class at offset 20 in /var/www/html/wp-content/plugins/bbp-messages/Inc/Core/Init.php on line 343

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter brianperera

    (@brianperera)

    The following link helped me. I was able to get the plugin to work

    https://wordpress.org/support/topic/after-update-site-to-php-7-3-the-plugin-stopped-working/

    thanks @brianperera for the tips, it solved the issue for me too.

    To be more precise, all users with a Z in the nickname will not be able to send a message, he will only be able to read the pm’s.

    For example, TEST can send and read PMs but TEZT can’t send PMs.

    • This reply was modified 3 months, 1 week ago by akira010203.

    Issue: usernames with a “z” in the name can not send a message ( PM ) with bbP Messages. Users trying the submit a reply with Send only finding an error ( or nothing ) and no message is sent. They can receive a message. The popup ” Error:Can not find chat!” is appearing also sometimes.

    I have tried the solution of replacing the \z with $ in the init.php file as described. Did not give the solution yet.

    Any other file that uses a regex expression that needs to be altered?
    Does the post-template message has to do anything with this perhaps?

    “Got error ‘PHP message: PHP Warning: array_unique() expects parameter 1 to be array, null given in …/public_html/wp-includes/post-template.php on line 838\nPHP message: PHP Warning: implode(): Invalid arguments passed in ….public_html/wp-includes/post-template.php on line 595\n’, referer: …/forums/users/{username starting with a z}/ ”

    I have made new accounts, varying username and /or email adresses and/or alias with and without the letter “z” in the string. Apparently the ( not to be changed) username is the one that triggers the errors.

    Anyone suggestions ?

    Kind Regards,
    Edwin

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.