Support » Plugin: Ultimate WP Mail » “Send Later” feature doesn’t work

  • Everything is great except for the “send later” feature. I don’t know if I did it properly but the plugin doesn’t really send the email on the scheduled time and date. I’ve put the schedule and the user to send the email to, then I clicked the “email user” button and it just stuck to loading “sending email…”

    I wish there could’ve been a “save schedule” instead or something like that.

    Update: I tried to make a schedule thru “quick edit”. The scheduled time and date were actually saved, but there was no field to put the recipient user, and the email wasn’t sent even to the default recipient user (admin email). Put a field on the quick edit section for the recipient

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Rustaurius

    (@rustaurius)

    Hi bruceandmrgiggles,

    Thanks for the feedback, would love to help get the plugin working correctly for your site. When you say the “send later” feature, do you mean the “Send Events” that you set up in the “Options” tab of the plugin?

    For the “quick edit” of the email, that would only make changes to the content of the email (ex. changing the subject line of the email), just like for a normal WordPress post, not schedule it to send at a certain time.

    Thread Starter bruceandmrgiggles

    (@bruceandmrgiggles)

    hmmm no im not talking about the options and send events tab, im talking about the sidebar options in the email editor… im trying to auto-send an email without any event triggers, just on a scheduled time and date.

    in that sidebar there’s a select option of whether to send the email now or later and whenever I choose “send later” a time and date picker appears I was able to give the schedule, but after that, the only button left was “email user” which I think is for the send-now type bcause it tried to send right away when it’s not supposed to, then it stuck to “sending email…” loading.

    now on the quick edit, I was able to give the schedule because it showed an editor for the time and date, it even showed a “-Scheduled” tag beside the email’s name/subject (originally no tag) when I saved the that time and date via quick edit. thanks for the reply btw!

    Plugin Author Rustaurius

    (@rustaurius)

    Hi bruceandmrgiggles,

    Thanks for getting back to me, and thanks for clarifying where you were trying to send later.

    The quick edit time/date option definitely won’t work, it’s just a default WordPress field for quick editing, we’re going to look into removing it in an update to avoid any possible confusion.

    I tested out the scheduled send feature on my development server, and was able to send without any issues. Here’s a screenshot of that:
    http://etoilewebdesign.com/Screenshots/Email_Scheduled_Send.png

    Does the email send normally when if you go to send it immediately instead of scheduling it? Was there any part of the date or time in the field that was left blank? If you’ve got a screenshot of the email you’re trying to send, and could send it to Contact@etoilewebdesign.com, that would be really helpful in terms of seeing any potential issues we might have missed.

    Thanks for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘“Send Later” feature doesn’t work’ is closed to new replies.