Support » Plugin: Contact Form 7 » Send, but displays no confirmation message

  • Never had problems with this plugin, always it worked perfectly, but recently, I believe that after upgrading to version 4.6, it sends the contents of the forms, however, does not display the success message “Message sent successfully” to the site visitor.

    Furthermore, it is displaying that animation arrows in a circle next to the “submit button” infinitely.

    Can anyone tell me what’s wrong? It will be a bug pluggin?

    Thank you 😉

    https://wordpress.org/plugins/contact-form-7/

Viewing 15 replies - 1 through 15 (of 15 total)
  • We are having a similar issue, however we are experiencing it slightly differently. In our case, when the form is completed and the SEND button is clicked, a very brief arrow animation follows, then nothing. The form does not reset, the success message does not appear, and worst of all the user does not think the form was sent which results in the user clicking the send button multiple times. Today we received the same form submission 46 times.

    We are receiving the form submissions, but it seems the front end confirmation is the issue. We are using a redirect code in the Additional Settings as follows:

    on_sent_ok: “location = ‘http://cockyclub.com/cocky-interviews/submit-cocky-interview/cocky-interview-submission-confirmation/’;”

    This code does not seem to work as the form does not redirect at all. When we removed this code and tested the form, everything worked perfectly fine, including the success message appearing and the form resetting. The functionality of the redirect is very important to our site’s promotional efforts, however, so getting this functionality to work is a priority.

    DISCLAIMER: Our website is adult-oriented.

    The form in question may be found at http://cockyclub.com/cocky-interviews/submit-cocky-interview/ and will have the redirect code enabled until this thread has been answered.

    I am having the same issues. Form data is being sent, but there is no notification (boxed green message) letting sender know that it has been sent. Just a tiny animation. Form does not clear. Please fix issue quickly. Thanks.

    I am getting this same problem. Our users submit the form several times due to no confirmation that it was sent.
    Any advice is appreciated.

    • This reply was modified 4 years, 8 months ago by kesseret. Reason: spelling error fix

    Same Issue here hope to find a fix for the problem soon!!!

    same here.. no confirmation message showing. been looking into it but nothing works.

    if i use any on_sent_ok: “ga(‘send’, ‘event’, ‘Contact Form’, ‘submit’);” code it stops functioning.

    any updates on this would be appreciated.

    I’m experiencing the same problem.

    I’ve temp. removed this code:
    on_sent_ok: "ga('send', 'event', 'Contact Form', 'submit');"

    marcel030,
    What are the results when you removed the code you mentioned? Also, what file did you remove the code from?

    @007bmorris, after I’ve removed the Google Analytics code CF7 works again.
    I therefor think that the on_sent_ok GA function has an error.

    One of my forms is on http://vlinderhof.com/contact/ and it includes this GA code

    	<!-- Google Analytics start -->
    			<script>
    			var _gaq = _gaq || [];
    			_gaq.push(['_setAccount', 'UA-****1912-*']);
    			_gaq.push(['_trackPageview']);
    
    			(function() {
    				var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    				ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    			})();
    		</script>
    		<!-- Google Analytics end -->

    Thanks for the information. I do not have a Google Analytics code in my form, so I guess this won’t help me. What theme are you running on your site? I an another guy I see on another forum are running the Divi theme. He is having same issues.

    Thanks for the info, I do not use Google Analytics either. But I am using Studiopress theme (out of the box one, no customization). Still experiencing the issue.

    SOLVED

    I’ve solved the problem. Since my theme is now using _gaq I had to change the code to:

    on_sent_ok: "_gaq.push('send', 'event', 'Contact Form', 'submit');"

    @marcel030

    where can i change that code ?

    this – on_sent_ok: “_gaq.push(‘send’, ‘event’, ‘Contact Form’, ‘submit’);”
    didn’t solve it for me. the “Message sent successfully”, stops working when i add any form of ‘on-sent-ok’ (i have tried all combinations/variations that i’ve found on the web).
    when i remove ‘on-sent-ok’ the “Message sent successfully” works fine again.

    basically i am doing it without any GA tracking at this time because i am getting people sending the form twice thinking it’s not working.

    Hi,

    Is this issue solved? I am having the similar problem with the latest version (4.7)

    thanks

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Send, but displays no confirmation message’ is closed to new replies.