Support » Plugin: WP Mail SMTP by WPForms » Send all WordPress emails via SMTP – Not working

  • I’ve latest 0.9.3 version of WP Mail SMTP plugin.

    Send all WordPress emails via SMTP -> option not working

    Use the PHP mail() function to send emails -> option working

    Why first option not working? I’ve used it before, and it was working.
    Its happening from last 3-4 months. May be I had wordpress 3.5-3.6 version.

    I tried with same mail server settings for both…

Viewing 15 replies - 1 through 15 (of 28 total)
  • I probably have the same issue.
    I work with 0.9.3 (using SMTP) and wp 3.7.1

    All worked fine up to 0.9.3, and the backup plugin I use, backwpup sent emails to me at the end of each backup, but now it stopped, on all my sites with the same configuration.

    The self-test email of wp-mail-smpt works fine.

    OK, I did one more test:

    I also use the plugin of “post notification”, so I used its test send feature and it failed, using the following (edited) data:

    The mail has not been sent!
    PHP-Mailer – Dump:

    object(PHPMailer)#<number> (<number>) {
    string(5) “UTF-8”
    string(9) “text/html”
    string(4) “8bit”
    string(35) “SMTP Error: Could not authenticate.”

    I’m getting “Could not connect to the server!“…
    But your seems authentication (user/pwd) error.

    I did a test and changed the delivery method of the plugin to be the PHP mailer option and now all the plugins send their emails correctly and without any errors.
    But, as I wish to use the SMTP option as it is more secure, I ask for this issue to be fixed.

    Try installing version 0.9.1, does the issue you’re experiencing go away?

    There were no changes to the logic, 0.9.2 and 0.9.3 were just bugfix releases. So upgrading shouldn’t have broken any SMTP functionality.

    No, the problem stil presit.

    Yep, the same issue happens with 0.9.1.
    Maybe something with the integration of the plugin with the new WP version of 3.7.x.

    Yes, same with 0.9.1
    +1 to eitanc

    So whatever issue you’re having is not related to the new release of the plugin, but has always been there, and it’s not an issue with the plugin itself, but something in the setup.

    @eitanc: You posted an error message that says “cannot authenticate”. That’s probably an issue with your SMTP username and password settings, or the server or port you’re using.

    Hi Callum,

    Thanks for checking this.
    But the plugin’s own test works fine with the veteran SMTP configuration, so I guess it is something about the integration between the other plugins and/or WP with your plugin.

    Could be, I’m not sure how the other plugins send emails, so can’t say about that. I understood from reading the thread that everything used to work, and since upgrading the plugin to 0.9.3 it stopped working, but it seems like that’s not correct.

    Personally, I’m using the plugin on WP 3.7.1 and v 0.9.3 and everything works fine. But I’m only sending mail to localhost, no authentication.

    Yes, you are correct – 0.9.3 is not the point, as it is happening also on 0.9.1 with WP 3.7.x.

    Can you try our configuration on a test site or similar?
    The Backwpup plugin will enable you to quickly use an email delivery feature.

    Alternatively, if you can direct us to somehow debug this issue and send you/post here the results, it will also be great.

    I can send with or without authentication, local or remote server. This plugin only activates features built into WordPress, it doesn’t do anything to actually send the emails.

    Was the plugin working for you on previous versions of WordPress?

    Yes it was.

    Try changing back to that version of WordPress, see if it works. Did you upgrade the other plugins? This is all outside of the scope of WP Mail SMTP. The plugin appears to be working as expected…

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Send all WordPress emails via SMTP – Not working’ is closed to new replies.