Support » Plugin: qTranslate X » Colon is being added to the widget title

  • Resolved stigekalder

    (@stigekalder)



    A colon is automatically being added to the widget title of the language chooser. So if title is “[:en]Change language”, it is displayed as “Change language:”.
    I don’t fancy that as it does not fit my design.
    It is so easy to add it manually, if you want it.
    Please can you drop this feature ?
    qtranslate or mqtranslate does not work like this.

    Best regards,

    https://wordpress.org/plugins/qtranslate-x/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Gunu

    (@grafcom)

    @stigekalder,

    see this on the FAQ – Can I change the look of Language Switcher Menu? –

    Maybe it can help.

    Success

    Well this might be an alternative.
    Although I hardly have space for one more menu item.
    And if I want to show flags, there is a problem with alignment.
    The flags are flying too high as compared with the text (there is the same issue with the widget).
    Is there a way to make bottom alignment ?

    In any case I still request that you don’t auto-append colon to the widget titles.

    If you don’t want this change, can you please inform how I can fix the code myself.

    Best regards,
    stigekalder

    Plugin Author John Clause

    (@johnclause)

    Yes, @stigekalder, collon is hard-coded, it may be removed through the filter ‘qtranslate_widget_title’ though, if you wish to get that deeply immediately.

    I did not want ‘:’ to mess with translation of the default title ‘Language’, and that is why it is separate. I should have added it to the default title only though, my bad …

    I will adjust it, but have not yet decided how.

    One way is to change it to be added to the default title only, that should not break people who use the default setting now. There are probably very little number of people, if any, who customized title and will want that collon back. They would need to enter it manually after this change.

    Other way, safe for everybody, is to add option ‘Hide Title Collon’, so that people, who use any setting now would not get affected at all.

    What would make better sense to you?

    Plugin Author John Clause

    (@johnclause)

    And if I want to show flags, there is a problem with alignment

    That depends on the theme, and it can be fixed with CSS, I believe.

    Plugin Author John Clause

    (@johnclause)

    @stigekalder: I added new option “Hide Title Colon” 3.2.1 – it is the safest way in order not to break anyone.

    Thanks John,
    Great solution, which solves the issue for me.
    I really appreciate your efforts with this, and in generally yours and others efforts to keep the qtranslate concert very much alive and even improve it in various ways.

    Thanks also from me for this little fix!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Colon is being added to the widget title’ is closed to new replies.