Support » Fixing WordPress » Self-hosted WP-Changing the Site URL-Locked out HELP

  • Resolved hibbardkitchen


    I have a wordpress blog that was located at We were using this as a testing site with the intention of changing the url/domain to (different url and with no ‘wordpress’ after it). I switched my wordpress hosting with godaddy from to, after following the wordpress article CHANGING THE SITE URL. I used the steps:
    Changing the URL directly in the database
    If you know how to access phpMyAdmin on your host, then you can edit these values directly to get you up and running again.

    1. Backup your database and save the copy off-site.
    2. Login to phpMyAdmin.
    3. Click the link to your Databases.
    4. A list of your databases will appear. Choose the one that is your WordPress database.
    5. All the tables in your database will appear on the screen.
    6. From the list, look for wp_options. Note: The table prefix of wp_ may be different if you changed it when installing.
    7. Click on the small icon indicated as Browse.
    8. A screen will open with a list of the fields within the wp_options table.
    9. Under the field option_name, scroll down and look for siteurl.
    10. Click the Edit Field icon which usually is found at the far left at the beginning of the row.
    11. The Edit Field window will appear.
    12. In the input box for option_value, carefully change the URL information to the new address.
    13. Verify this is correct and click Go to save the information.
    14. You should be returned to your wp-options table.
    15. Look for the home field in the table and click Edit Field. Note There are several pages of tables inside wp_options. Look for the > symbol to page through them.
    16. In the input box for option_value, carefully change the URL information to the new address.
    17. Verify this is correct and click Go to save the information.
    18. Delete the folder wp-content/cache (this is a new folder added with WordPress 2.0).
    19. That is it.
    The steps above were also provided in Godaddy’s Fixing A Broken WordPress guide.

    So, after these steps, I was at the point where my was being properly hosted at godaddy (they checked it), but it was not connecting to my wordpress blog I created and I was/am still locked out of my wordpress admin.

    Were there steps I was missing?

    This is the error you get when you go to
    Warning: require_once(/home/content/58/7003058/html/wp-settings.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/58/7003058/html/wp-config.php on line 91
    Fatal error: require_once() [function.require]: Failed opening required ‘/home/content/58/7003058/html/wp-settings.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/58/7003058/html/wp-config.php on line 91

    I can’t log in to my wordpress control panel from either:

    Does anyone have suggestions for me? Godaddy said everything looks correct on their end, but in my hosting app for WordPress on godaddy, it showed:
    Primary domain:
    URL: exampletest.COM/wordpress/

    So, I think I needed a solution to change the ALIAS and the URL, but godaddy couldn’t help me.

    I am now trying to restore my wordpress hosting back to it’s original url and godaddy says the DSN servers have to propagate. So, as of right now, I can’t log into my wordpress or access my original wordpress url (I get a 404 error) for 24-48 hours.

    Can anyone shed some light on what went wrong? Also, is there an easy way to redirect visitors to from without the difficulty of going through all the steps I already did?

    I backed up all my database files/folders/destinations, so if I wanted to start a new wordpress at, how would I load all those database items into a new wordpress account?


Viewing 1 replies (of 1 total)
  • hibbardkitchen


    If this happens to anyone else and you have hosting through godaddy, you can go to your file manager and restore your databases/directories back to a previous date. I actually had godaddy walk me through pointing my wordpress to the root, instead of the subdomain ‘/wordpress’.
    I set my restore date back to the day before yesterday and the site was back up and running. The only issues I had after the restore and removal of the subdomains was that my image path was showing up wrong for 800+ photos. So, I installed Velvet Blues search and replace plug-in. I am now back to 100%.

Viewing 1 replies (of 1 total)
  • The topic ‘Self-hosted WP-Changing the Site URL-Locked out HELP’ is closed to new replies.