WordPress.org

Support

Support » Plugins and Hacks » [Resolved] selective plugin loading settings not saving

[Resolved] selective plugin loading settings not saving

Viewing 15 replies - 1 through 15 (of 32 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    Are you running version 2.5.1? Are you disabling the plugins from the page edit screen or the url admin?

    I am running the latest version. I’m trying to disable the plugins from the page edit screen. When I try to add something to url admin I get: “There was a problem adding the URL”.

    Plugin Author Jeff Sterup

    @foomagoo

    Can you turn on WP_DEBUG to see if you are getting any errors? To turn it on open your wp-config.php file and set WP_DEBUG to true and you will see any errors. Let me know if you see any errors. Are you running on a windows server?

    Yes, I am on a windows server. I am getting this error that shows up when I go to Plugin Organizer > Settings:

    Notice: is_plugin_page is deprecated since version 3.1 with no alternative available. in C:\inetpub\wwwroot\wpcp\wp-includes\functions.php on line 2640 Notice: is_plugin_page is deprecated since version 3.1 with no alternative available. in C:\inetpub\wwwroot\wpcp\wp-includes\functions.php on line 2640 Notice: is_plugin_page is deprecated since version 3.1 with no alternative available. in C:\inetpub\wwwroot\wpcp\wp-includes\functions.php on line 2640 Notice: is_plugin_page is deprecated since version 3.1 with no alternative available. in C:\inetpub\wwwroot\wpcp\wp-includes\functions.php on line 2640

    Does the plugin work for the latest version of wordpress?

    Plugin Author Jeff Sterup

    @foomagoo

    I’m running the latest version of wordpress and it is working fine. That error isn’t coming from plugin organizer. What errors do you get when you try to disable plugins?

    I get this :

    WordPress database error: [Table ‘wordpress.wp_po_post_plugins’ doesn’t exist]
    SELECT * FROM wp_PO_post_plugins WHERE post_id = 34

    Plugin Author Jeff Sterup

    @foomagoo

    Ok that is the problem. The user your web server is accessing the database as must not have rights to create tables. Run these sql commands on your database to create the tables needed.

    CREATE TABLE wp_PO_groups (
    group_id bigint(20) unsigned NOT NULL AUTO_INCREMENT,
    group_name varchar(255) NOT NULL default '',
    group_members longtext DEFAULT NULL,
    PRIMARY KEY PO_group_id (group_id)
    );
    
    CREATE TABLE wp_PO_post_plugins (
    post_id bigint(20) unsigned NOT NULL,
    permalink longtext NOT NULL default '',
    disabled_plugins longtext NOT NULL default '',
    enabled_plugins longtext NOT NULL default '',
    PRIMARY KEY PO_post_id (post_id)
    );
    
    CREATE TABLE wp_PO_url_plugins (
    url_id bigint(20) unsigned NOT NULL auto_increment,
    permalink longtext NOT NULL default '',
    children int(1) NOT NULL default 0,
    disabled_plugins longtext NOT NULL default '',
    enabled_plugins longtext NOT NULL default '',
    PRIMARY KEY PO_id (url_id)
    );

    This is what it gives me now.

    Error Code: 1101. BLOB/TEXT column ‘permalink’ can’t have a default value

    Would you know how to setup the user accessing the server to have writes to create tables?

    Plugin Author Jeff Sterup

    @foomagoo

    That is apparently a limitation on MySQL for windows. I can get rid of the default for this column but I will need some time to test my changes. I’m going to make the change to my database now and see if any problems arise. I should be able to get it all tested and released some time this afternoon. Maybe not until tomorrow.

    I modified mysql.ini and fixed the problem.

    Setting the sql-mode to sql-mode=”MYSQL40″ fixes the issue.

    rolled back to version 2.5, now it works. pls fix it when releasing 2.5.2. thanks!

    Plugin Author Jeff Sterup

    @foomagoo

    Rolling back to version 2.5 wouldn’t have fixed the problem with the default for BLOB/TEXT column in the database. That has been there since version 1. I’ve got version 2.5.2 ready to release but I’m not sure what problem you were having prejudice.

    sorry Jeff. the problem i had in 2.5.1 is a little bit diff. in Settings page, every time i select Enable in Selective Plugin Loading, then Save Settings. refresh the page, it becomes Disable… tried many times all the same. i’m not sure what’s the issue there, so i rolled back to 2.5 and it works. thanks.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] selective plugin loading settings not saving’ is closed to new replies.