Support » Plugin: Hyyan WooCommerce Polylang Integration » Selecting page=mlang_settings and my shop page is empty

  • hi,

    Maybe some else stumble upon the same problem i have. My problem is the following: – when i am in the wordpress admin section and i select languages->settings (url goes to page=mlang_settings) my woocommerce shop page is empty???
    I can fix this by selecting Custom post types and Taxonomies -> Settings and save it again.

    My explanation is every time i select languages > settings all ml_lang_settings are set to default??

    How can i fix this?

    ps: i am developing locally,
    wordpress 4.9.8
    woocommerce 3.4.5
    polylang 2.3.11
    hyyan 1.0.2
    php 5.6.12

Viewing 3 replies - 1 through 3 (of 3 total)
  • i also notice when Hyyan WooCommerce Polylang Integration plugin is enabled i can not edit product data.
    Is this normal??

    No it is not 🙂

    Plugin Contributor jonathanmoorebcsorg

    (@jonathanmoorebcsorg)

    I don’t understand any of the first part of the question.

    “when i am in the wordpress admin section and i select languages->settings (url goes to page=mlang_settings) my woocommerce shop page is empty???”
    What settings are you trying to change?
    The option “The language is set from content” is not supported as mentioned in the plugin documentation (the content needs to change to match the current language, not the other way round), but everything else should be fine.

    “I can fix this by selecting Custom post types and Taxonomies -> Settings and save it again.”
    fix what? changing what setting?
    So you say you visit the page and without changing anything the shop page becomes empty?
    And then you press save, also not changing anything and the shop page appears again?
    I think there is some detail missing here.

    “My explanation is every time i select languages > settings all ml_lang_settings are set to default??”
    What do you mean, “set to default”, for example what setting?

    For the second question re disabled content, see previous support topic and related documentation:
    https://wordpress.org/support/topic/cant-edit-product-attributes-2/

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Selecting page=mlang_settings and my shop page is empty’ is closed to new replies.