Support » Plugin: Organize Series » Select series/part on quick edit doesn't seem to work

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same with me, ? since upgrading to 3.5.1.

    Organize Series not appearing at all on “multiple quick edit” (otherwise known as bulk-edit), is currently by design. Working out an easy to understand ui for that is tricky because someone may select multiple posts that are part of multiple series…

    As for updating series on quick edit, I’m assuming you mean that when you change the part number it doesn’t update (but otherwise quick-edit works as expected). This is a known issue and if memory serves me correctly the fix I mentioned in here -> http://wordpress.org/support/topic/on-editing-a-post-the-series-reorders-it-self?replies=9 works to fix this issue as well. You can try it and see if that helps.

    We are planning on releasing an update to Organize Series that will fix these issues within a few days.

    Thanks very much. Rather than doing a hack that might have side effects, I will wait for your update.

    Thanks!

    Thank you for your reply.
    I completely understand the bulk-edit part, is not required at all but can make things a bit faster.

    About the quick-edit, nothing related to Organize series is saved when I press the Update button and the variable name change from the other thread doesn’t seem to fix it.

    Sorry for my english, by the way, and thanks again for your time.


    Some more details: series ID is correct, but the series_post_id is empty so probably the data is saved somewhere but not correlated with the post id.
    ...&post_series=14943&series_part%5B14943%5D=1&series_post_id=&...

    no problem with the English 🙂

    I’ve created a ticket for our team to try to reproduce.

    In the meantime, I’m assuming you are using the latest version of WordPress and Organize Series. Can you confirm that please?

    Also, it is possible you may have a conflict with another plugin that loads javascript. Can you try temporarily deactivating all plugins except organize series and see if that fixes the issue? If it does, reactivate the plugins one by one until you find which one breaks the quick edit saves for Organize Series and report back here. If its a conflict we can fix, we will.

    Thanks.

    Yes, I am using the latest version of WordPress and Organize series and I’m also testing locally where there’s no plugin besides yours.

    I have added $('.series_post_id').val(id); inside inline-series.js and now the series_post_id post value is correct but the problem persists.

    I’m unable to reproduce. Just to clarify as well.

    Are you using a default theme (such as Twenty Twelve) or a custom theme?

    Are you trying to edit published posts or scheduled/draft posts?

    Another thing you might want to try (especially if you upgraded from an older version of Organize Series) is to empty your browsers cache.

    Default theme, tried both published and draft.
    I have installed the plugin locally just an hour ago.

    Weird stuff 🙂
    *Tried also in different browsers.

    That is weird. However, when I ran my test it was on a devleopment copy of Organize Series that includes the fix I mentioned earlier. I just tried 2.4.4 and I AM having the problems. So, you can try that fix again, or just wait until we release the updated version (hopefully this weekend but might not be till early next week)

    Are you sure that the only fix from the dev version is the variable name change from $ispublished to $is_published?

    no there’s another fix that is related that I forgot about (a lot of projects on the go these days, sorry).

    Anyways, you can get the latest development version of Organize Series via the public git repo here -> https://github.com/roughsmoothengine/organize-series/tree/development

    Great stuff, thanks a lot!
    For a future version, if it is possible to check the part number so users can’t add part 15 of 10 (total) for example.

    It’s *supposed* to do that already. There is logic in the code to automatically reduce it to the latest incremented part number if the part set is more than the total parts +1. We’ve been working on fixing things with scheduled and draft post ordering though so if its not working as expected it probably got broken.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Select series/part on quick edit doesn't seem to work’ is closed to new replies.