Support » Plugin: Woocommerce Minimum and Maximum Quantity » “Select options” URL parameter causes 404

  • Resolved awpulley

    (@awpulley)


    It has been pointed out to me that, for products on our site where we apply your plugin, some links are generating 404s.

    On the category page at the link I provided with this post, both of the Baffle Hood Filter products have a minimum quantity of 2. The images for these products have normal links and take the user to the product page intended. But the “Select Options” buttons have links with “&quantity=2” added, and take the user to a 404 page. I can remove the “&quantity=2” by disabling the minimum quantity, and then no more 404 is produced, so I feel sure that is the problem.

    Could you please look into this issue?

    When I click the images (which always have links without the “&quantity=2”) to go to the product page, the page still displays with the quantity correctly pre-set to 2 and enforced as a minimum, so I don’t think the “&quantity=2” is necessary to add to the link.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ashok G

    (@wpashokg)

    @awpulley,
    I’m unable to reproduce the issue in the page that you’ve mentioned.

    We have reproduced it with several people/workstations on my end.

    When you follow the link, you should be at a WooCommerce category page entitled “Research Products”. Note there are two “Baffle Hood Filters” products listed on the page.

    Hover over the image for either of them, and you will see the link displayed in the bottom-left of the browser (in Chrome). Click on these images, and they will work properly with no 404s.

    Go back to the “Research Products” category page. Now find the same two products and hover over the “Select options” buttons below their images. The links displayed will be the same as for their images, except with the parameter “&quantity=2” added at the end. Click these buttons, and you will get a 404.

    Please try this and see what you find. Again, I can toggle this error on and off by enabling and disabling the min/max quantities for the product.

    Plugin Author Ashok G

    (@wpashokg)

    @awpulley ,

    Thanks for pointing out the bug, since we don’t support variable products we didn’t test the above scenario. Now I’ve added the condition to remove 404 pages.

    But one more heads up. This plugin doesn’t support variable product. It’s still in progress.

    I’ve the same 2 or 3 versions ago it wasnt a problem is there no change something in the code manually ?

    awpulley

    (@awpulley)

    Installed your update. Looks like my problem’s fixed! Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.