Support » Plugin: Yoast SEO » Select multiple Gutenberg blocks broken?

  • Resolved ma_wordpressorg

    (@ma_wordpressorg)


    I was just trying to select multiple Gutenberg-blocks via click-and-drag. It was working on one site and not on another. I found out it was yoast, that prevents this. Anyone can confirm this behaviour? I also tried it with twentytwentyone and I couldn’t select more than one block there too.
    Shift and Click works.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @ma_wordpressorg

    We had a test site with WordPress 5.7.2, a default WP TwentyTwenty theme, and only Yoast SEO v16.5 as the plugin enabled. We can confirm that shift and click works and we can rearrange multiple Gutenberg blocks.

    However, would it be possible for you to provide exact steps on how to reproduce this issue with the click-and-drag for the blocks so we can understand this better? And just to clarify, when you temporarily disable the Yoast SEO plugin, the functionality of click-and-drag then works as expected?

    Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    Jap, I can confirm, if I deactivate Yoast the functionality comes back.
    It’s like you would select Paragraphs in Word: Go into some point into your paragraph and do a click-drag to select all paragraphs you like.
    Standalone Gutenberg then starts selecting all the blocks your drag over with your mouse. With Yoast active I can only select one block and no more.
    I deactivated all other plugins to be sure. Themes I tested with: twentytwenty, twentytwentyone and my own one. Shall I report this in your bugs in github?

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @ma_wordpressorg

    Would it be possible for you to share some screenshots or a video recording of exactly what you mean on this as I’m not quite sure I totally understand what the issue is.

    On my test site with WP 5.7.2, default TwentyTwenty theme, I edited a test post and highlighted the first 3 paragraphs. Then I went and enabled Yoast SEO v16.5 and then edited the post again, and was still able to highlight all 3 paragraphs. Is this similar to the issue you mentioned? You can check out the video here – https://www.loom.com/share/d6e0c86e17e84509a4eec7ca2c564c48

    Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    Your Recording exactly does, what I would expect it to behave. I just found out it works in Chrome (91.0.4472.114) and I was editing the site in Firefox (89.02).
    As far as I have tested, this only happens in Firefox (older Version too). Safari, Chrome and Edge behave like your video.
    Thanks a lot for your help. For now, this issue is solved for me. I only have to watch out not to develop the other way round. šŸ™‚

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.