Support » Fixing WordPress » Select image from media library, then crop white screen

  • Resolved davi8r

    (@davi8r)


    I started having this issue about 3 months ago. When I try to add an image to a post or when customizing site identity (logo, site icon), I’m taken from media library-> select image, to a white screen entitled Crop Image. I’ve tried this with images as small as favicon.png (16X16) up to a 3000 X 3000 featured image. The common denominator is, after selecting an image in media library, I wind up at a Crop Image screen, the center area is white showing no image(s) to select from. There is a select button at the bottom that doesn’t work, because there is no image to select. There is also an X at the upper right which thankfully works, allowing me to navigate back to where I started but without the image selection that I was trying to accomplish.

    Here’s the relevant Site Health info:

    Active editor WP_Image_Editor_Imagick
    ImageMagick version number 1673
    ImageMagick version string ImageMagick 6.8.9-9 Q16 x86_64 2018-12-14 http://www.imagemagick.org
    Imagick Resource Limits
    area: 3 GB
    disk: -1
    file: 98304
    map: 3 GB
    memory: 1 GB
    thread: 1
    GD version bundled (2.1.0 compatible)
    Ghostscript version 9.26

    The main WordPress directory Writable
    The wp-content directory Writable
    The uploads directory Writable
    The plugins directory Writable
    The themes directory Writable

    I’m just not sure where to start looking. One possible hint is that I’ve had Regenerate Thumbnails (current 3.1.3) on the site for years. With all the improvements to core and WC I wanted to try running the site without this plugin. So I ran RT with “Delete thumbnail files for old unregistered sizes” checked. Since then I’ve tried to add images with Regenerate Thumbnails active and deactivated, with no change in behavior. I also have Enhanced Media Library installed and active, which I have used on the site for years to manage a separate set of product images. I also ran these tests with two entirely different themes active (different publishers and frameworks), but got the same behavior.

    I suspect the problem might be associated with WP’s image editor, but am not sure. Any suggestions will be appreciated.

    Thanks,
    — Dave

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and switch to the default Twenty Twenty theme. If the problem goes away, enable them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    if you are using ‘enhanced media library’ plugin deactivate it, that solved this problem for me

    Thread Starter davi8r

    (@davi8r)

    broberts thanks! I deactivated EML and that solved it!

    James H thanks for letting me know about Health Check. I am going to start using it. I will open a support ticket with the developers of Enhanced Media Library and am marking this thread resolved.

    — Dave

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Select image from media library, then crop white screen’ is closed to new replies.