Support » Theme: Sela » style.css fail to load once in a while

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Hi Boris, that is odd, I haven’t seen this issue before with Sela, but it sounds network or hosting-related.

    The next time it happens, you could try running a traceroute and see what results you get:

    Advanced Browser Troubleshooting

    Thank you for your quick answer. I’ll try and have a look at that next time it happens.

    Have a nice week.

    Boris

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Sounds good. Have a lovely week too.

    Hi !

    So the problem happened again, in Google Chrome’s private navigation mode.

    The recurring error seems to be :
    Fail to load resource: net::ERR_CONNECTION_RESET
    on 4 CSS files :

    1. sela’s,
    2. sela’s child theme’s,
    3. jetpack’s
    4. instagram feed’s

    I took 3 screenshots to try and debug :

    I failed to take a screenshot of the Network > Headers part, sorry.

    I’m currently searching the web for a solution but any help would be welcome 🙂

    Thank you in advance,

    Boris

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Hmm – the “fail to clear temp storage” error looks browser-specific. Can you try a different browser the next time this happens, like Firefox? It could be something up in Chrome.

    Hi !

    So I may have find a reason for this problem. Thanks to Google Search Console, I figured out there were two versions of my site : the http one and the https one. And the thing is images displayed using absolute URLs (with http in them) failed to load, and so did stylessheets.

    I didn’t even know SSL was included in my hosting plan but, anyway… After some researches and a lot of tries and errors, I managed to edit the .htaccess file to redirect https to http, by adding the following code above all the code already added by WordPress :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} on
    RewriteRule ^(.*)$ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    
    # BEGIN WordPress etc.

    It really is important to add this BEFORE WordPress generated code, or else it will not work (because of the L flag in WordPress Rewrite rules ?).

    I’m not sure this solves all loading problems, but I guess so, so I will mark the topic as “solved”.

    Thanks again for your help Kathryn 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘style.css fail to load once in a while’ is closed to new replies.