Support » Plugin: 404page - your smart custom 404 error page » Seems to work now but inconsistent behavior noted

  • I do like that it leaves the bad url entered in the address bar, and does not change it to the destination page, as many other 404 plugins do. That makes it easier for the user to see if they mis-typed, and can edit easily.

    However, under some circumstances, mangles header information on page and page layout. Theme is Avada 5.1.6. Reinstalled it several times and found if I create a destination page after installing that plugin, that page has a mangled header. If I create the page first and then install the plugin, seems to work as expected. At one point it seemed to be working then a day later after other changes to the site, mangled header returned. Maybe compatibility mode is helping, because I can’t seem to recreate the problem now.
    Will continue to monitor for changes in behavior.

    Advanced settings is confusing and ambiguous – all ? links for descriptions for these features go to page not found! Shouldn’t the author be using his own product?!

    • This topic was modified 3 months, 2 weeks ago by  James Huff.
    • This topic was modified 3 months, 1 week ago by  mcowtan.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Peter Raschendorfer

    (@petersplugins)

    It would have been meaningful you would have created a support ticket to give me the chance to help you making it work instead of immediately giving the plugin a one star rating. I really do my best to make it work with as many themes as somehow possible.

    Would you please post a link to your site. I’ll take a look at it. Maybe the problem can be fixed.

    Regards,
    Peter

    Yes you’re right – my apology. I’ve tried it again, and it magically seems to be working a lot better, and I cannot reproduce the original error I had. I’ve upgraded to 3 stars. Unfortunately I cannot give you access to the system, we’re days away from launch, and cannot take an more detours. Thanks for challenging me…my mistake, posting a bad review. But read the update there is still something you need to attend to.

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Thanks a lot for adding a more detailed description. The Avada Theme is a premium theme, so normally I would not have access to it. Thanks to the guys at Theme Fusion they sent me a copy for testing it a few months ago. So currently I do not have the latest version here. The version I have is 5.0.6. And all I can say at the moment is that everything works fine with this version. I’ve retested it just now. Of course I’ve just created a very simple test site but as far as I can judge everything seems to be fine.

    I’m pretty sure there’s a compatibility issue with another plugin you are using. Please check https://petersplugins.com/please-follow-these-simple-steps-if-you-have-any-problems-with-one-of-my-plugins/. But I think the reason will be hard to find if the problem does not appear every time. Would be great if you could find out because I’m always interested in making this plugin even better.

    Thanks also for letting me know that there was a problem accessing my website. Of course I regularly check if everything works. And on my machine everything was fine so far. But trying to access the manual page from my mobile also resulted in an error. After checking everything I found out that it is an DNS issue. I could not see the problem on my machine due to DNS caching. It was not a problem on my server. The problem was caused by Cloudflare. After purging the Cloudflare cache it worked immediately. For whatever reason. I did not change anything the last few days. I’ll keep watching this.

    Regards,
    Peter

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this review.