Support » Plugin: GD bbPress Attachments » Seems to not work with 4.4.2

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Milan Petrovic

    (@gdragon)

    I can’t find any issues, it works fine with 4.4.2. If you can provide me with errors or exact problems, I might be able to test further, saying that it is not working is not very helpful, without providing details.

    Todd Gibson

    (@oliverands)

    Thanks for your followup, and sorry about the incomplete nature of my first post here.

    I subsequently did more testing and determined that the plug in works with core bbPress posts. It seems to be an incompatibility with BuddyPress.

    The plugin allows uploads of attachments on standard topics, but it does not allow uploads to forums created within groups that have been made using BuddyPress.

    See this topic, for example:

    http://oliverands.com/community/groups/sew-alongs/forum/topic/gallery-tunic-dress-sew-along/page/4/

    It is in a BuddyPress group. The topic allows for posts to have images included if they are hosted offsite and placed using html in posts. But when you try to upload images directly to a post, they do not get attached.

    This is not an issue specifically with gd-bbpress-attachments. Rather, gd-bbpress-attachments is relying on the bbpress function is_bbpress() to determine when to include the js & css. I’ve submitted a patch to bbpress to fix the root issue: https://bbpress.trac.wordpress.org/ticket/2974

    In the meantime, one can check the “always include” checkbox in the admin panel for gd-bbpress-attachments.

    Should bbpress not address this issue in their next release, it might be wise for gd-bbpress-attachments to work around it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Seems to not work with 4.4.2’ is closed to new replies.