Support » Plugin: WP Page Extension » Seems to break links to other pages with 404

  • Hi,
    this appears to break links to other pages.

    For example; activated, turned off the YoastSEO ‘add trailing slashes’ to pages function (page/); went to test page, clicked radio for .xml extension for test file. Worked.

    However, all links to other pages such as site/about or site/contact come up with 404 error.

    So, this seems to activate a redirect for “all” pages even when a type is not selected for an existing page (e.g., default not default).

    When activated
    site/mypage.ext – works
    site/about – 404
    site/about/contact – 404

    When off
    site/mypage – works
    site/about – works
    site/about/contact – works

    Impacts the menus top of page, and widget area with list of pages as well as direct entry of the /site/page

    This appears to imply a setting MUST be done for each page, but have not tried that. Obviously we do NOT want to add extensions to certain pages which are already indexed properly.

    So, this “almost” rocks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Wow! I am having the same issue exactly. Did you test going to each page and setting each page. Seems that if I go to any other page and save as NO EXTENSION then it unchecks the asp extensions on other pages.

    If you have gotten this to work please let me know!

    I just went in and double checked the individual page settings and it seems to be an ALL OR NOTHING setting. Perhaps this is a bug that is easy to fix. I hope so we really need this to work.

    I am having a similar problem, my pages all need the extension .html and I individually set all the pages as such, it will work for a while and then start coming up 404 because it reverted back to no extension with no change from me. I go back in a change the pages back and it will work for a while and then do the same thing.

    Any suggestions?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Seems to break links to other pages with 404’ is closed to new replies.