Blog Copier
[closed] Seems to be broken in 3.5.1 (missing slash in URL) (6 posts)

  1. websta
    Posted 3 years ago #

    In 3.5.1, it appears to leave off a slash on the client site that is created, so the URL is http://nameofyoursite.comclientsite/ and does not work.

    This was while creating an entirely new client site via the plugin.


  2. websta
    Posted 3 years ago #

    Here's the fix for Blog Copier plugin (based on http://wordpress.org/support/topic/sub-site-missing-after-351-update):

    1. Go to:

    2. Type Ctrl+F ("find" in browser) for:
    $path = trailingslashit($base.$domain);

    3. Replace that line with these two lines:

    $base = trailingslashit($base);
    $path = trailingslashit($base.$domain);

    4. Click "Update File."

    5. To copy a site, go to:

    6. Fill out the form and go from there. It should work, copying the site you like to another location, including all files, and settings (including images, posts, Pages, etc.)

  3. robinconn@gmail.com
    Posted 3 years ago #

    I tried this fix and it did not work. I have tried adding the "/" in front of the new site....no luck. I really hope this can be fixed.

  4. digitalnordic
    Posted 2 years ago #

    It worked for me - thanks!

  5. Jeff
    Posted 2 years ago #

    Would be nice if the developer could fix this very simple thing. It's only been 9 months.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    @Jeff: If you require assistance then, as per the Forum Welcome, please post your own topic.

    This topic references an old version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Blog Copier
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic