Support » Plugin: Woocommerce Custom Tabs » seems not to work with wc 2.3.x

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WebshopLogic

    (@webshoplogic)

    Hi Oblaum!

    We have tested the plugin with Woocommerce 2.3.7, it works perfectly in our environment.
    Please let us know what is the problem exactly, a screenshot may also be help to see the problem.

    Peter

    I’m also having trouble with how a WebshopLogic plugin works with WooCommerce. The “Shop” page I have has broken formatting, when the WP Related Items (WRI) by WebshopLogic plugin is active. When I turn off the related items plugin, the Shop page works again.

    Plugin Author WebshopLogic

    (@webshoplogic)

    Hi,

    This is a forum of Woocommerce Custom Tabs plugin, and you mentioned “WP Related Items (WRI)” plugin, and the original post is not related to this issue.
    We do not understand exactly if the problem is about Custom Tabs or Related Items plugin?

    If this post is related to WP Related Items plugin, I suggest you to switch on one or more of the following settings on the plugin’s settings page:
    -Disable YARPP related.css stylesheet
    -Disable YARPP widget.css stylesheet
    -Disable WRI styles-wri-thumbnails_woocommerce.css stylesheet

    In this general purpose plugin, we try to apply built in css stylesheets that is right for most sites and most themes. But of course in special cases there can be conflict between the built in css stylesheets of the plugin and your stylesheets of your theme. That is why these settings are made.
    If you disable these stylesheets in the plugin using the settings above, your theme or custom css stylesheets are responsible for the appropriate formatting of related items, and you have the possibility to apply some more custom css that fit to your formatting needs.

    I hope this information is help you to solve the formatting problem.

    Peter

    Same problem here. I’ve gone through all the posts I can find on this subject and tried everything. When the plugin is active, the formatting on my shop and product category pages gets messed up. I disabled all YARPP stylesheets but no effect.

    I also can’t even get the related products to show up at all on a product page. I’ve gone through every setting but nothing works. If I turn off the plugin then the default WooCommerce related products appear. With the plugin on, nothing shows up.

    Not sure what else to do. I just thought I’d post here in case there is something I’m not thinking of. Seems to work for everyone else so I’m guessing it’s my theme, although I’m just using the Woocommerce Mystile theme out of the box.

    Thanks.

    Plugin Author WebshopLogic

    (@webshoplogic)

    Can you send us the URL, where the issue appeaser?

    The site is http://www.curate-co.com. I’ll turn the plugin back on if that helps.

    Category pages are supposed to be 3 products across but with plugin on, they wrap at only 2. No related products show up at all.

    Thanks for your response.

    Plugin Author WebshopLogic

    (@webshoplogic)

    I see the problem on your site.

    I have created a test site with Mystile theme, but there everything is all right, so I cannot reproduce the problem. However I have a 4 columns display. I suppose that the problem is related to the 3 column display.
    Can you tell me, how do you set 3 columns in Mystile? I would like to set similar appearance to reproduce the problem in our test site.

    Hi, thanks so much for taking the time to troubleshoot this, I appreciate it.

    So, your comment made me realize that I had, in-fact, added some custom CSS to the Mystile theme to change the 4 columns to 3 columns. That custom style was:
    .woocommerce-page ul.products li.product {width:30%}

    I removed that and the category pages are now displaying correctly (at least 4 across correctly). I’m not sure what the plugin does to the category page to break the width:30%, but I can play with that.

    More importantly, the related products are still not displaying at all. I saved the options again in the YARPP plugin and WRI plugin just to make sure things refresh, but nothing changed.

    Please let me know if you see anything strange that I can try testing on my end.

    Thanks again.

    Plugin Author WebshopLogic

    (@webshoplogic)

    Hi,

    In case of every forth product there is a last class applied by Woocommerce inside of <li …> tags.
    E. g. in your site at the 4. picture:
    <li class="last post-589 product type-product status-publish has-post-thumbnail product_cat-best-sellers-eyewear product_cat-eyewear product_cat-eyewear-men product_cat-new-arrivals-eyewear product_cat-ray-ban-eyewear product_cat-womens-eyewear pa_color-brown pa_color-tortoise pa_eyewear-lens-size-55mm pa_lens-non-polarized pa_frame-style-retro pa_frame-style-wayfarer featured taxable shipping-taxable purchasable product-type-simple product-cat-best-sellers-eyewear product-cat-eyewear product-cat-eyewear-men product-cat-new-arrivals-eyewear product-cat-ray-ban-eyewear product-cat-womens-eyewear instock">

    So if you would like to change the number of columns, you should change that the last class be applied for every desired occurrence of products. If I remember well, there are plugins or filters for this reason.

    I have tried .woocommerce-page ul.products li.product {width:30%} css in my Mystile theme test environment, and there was not any difference if the plugin was activated or not. In both case there was a two column display (not three). So unfortunately I could not reproduce this case.

    If there are not related items are displayed, then the similarity may be under the threshold level. So please set a lower threshold, and try to increase the similarity by using common categories.
    You can find more information here, this is the documentation of PRO version, but may be useful if you use Lite version:
    http://webshoplogic.com/product/wp-related-items-pro-wri-wordpress-plugin/#tab-faq

    Sometimes there are problems with full text search in the database, you can find more information about it on YARPP forums, e.g. if you search for “ISAM” in Google.
    E.g. this topic: https://wordpress.org/support/topic/relatedness-options-unchangeable?replies=4

    I hope these information will help to solve the problem.

    Peter

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘seems not to work with wc 2.3.x’ is closed to new replies.