Support » Plugin: WebP Express » Seems great but…

  • Nice plugin! But I can’t get it to work because I dont have access to the php.ini file to enable exec() on a managed wordpress website. Is there an alternative?

    Cheers!

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author rosell.dk

    (@roselldk)

    The exec() function is only required by some of the conversion methods (cwebp, imagemagick and graphicsmagick). You can still use the rest of the “local” conversion methods (vips, Gd extension, Imagick extension, Gmagick extension). If you cannot get one of these to work either, you can set up WebP Express on a server where you can, and connect to that. Or you can buy an api key to ewww and connect to that. They are extremely cheap. 99c startup fee and free webp conversions from there (they might change their pricing, I have no control over that)

    Plugin Author rosell.dk

    (@roselldk)

    Thanks for the quick reply! I got this message when I re-activated it though:


    You are not on Apache server, nor on LiteSpeed. WebP Express only works out of the box on Apache and LiteSpeed.
    But you may get it to work. WebP Express will print you rewrite rules for Apache. You could try to configure your server to do similar routing.
    Btw: your server is: nginx/1.14.2

    However..the only green arrow I got was ‘gd extension’ in the list. I’ll move that to the top and try that…

    Plugin Author rosell.dk

    (@roselldk)

    Ok, you are on Nginx then. I should remove that warning for Nginx because it is well tested on nginx. It is however still on the roadmap to adjust the UI for nginx. Also beware that the .htaccess rules does not take effect on nginx. In order to get that functionality, you need to insert redirection rules manually. Check out the “I am on Nginx” section in the FAQ: https://wordpress.org/plugins/webp-express/#i%20am%20on%20nginx%20or%20openresty

    Question..How do i see if the images are getting converted? The only one that works is the GD with the GD converter…but when I refresh a non-logged in browser on an image it’s still a .jpg….

    Plugin Author rosell.dk

    (@roselldk)

    Did you check out the “I am on Nginx” section in the FAQ ?
    You should start there.

    If you decide not to use varied image responses, you simply do a bulk conversion and check the HTML. If you decide to set up redirection rules manually, you can check if these works by the method described in the “How do I verify it is working” section in the FAQ: https://wordpress.org/plugins/webp-express/#how%20do%20i%20verify%20that%20the%20plugin%20is%20working%3F

    Ok thanks I tried CDN-friendly, bulk converted, cleared browser cache, purged cache on my CDN but still no luck seeing the converted image in the browser. And I don’t believe this is true: “Images in external CSS and images being dynamically added with javascript will not be served”

    Ugg..it also broke all the theme images on my site 🙁

    Plugin Author rosell.dk

    (@roselldk)

    Where did you see that text? (“Images in external CSS and images being dynamically added with javascript will not be served”). I should correct it to “Images in external CSS and images being dynamically added with javascript will not be served AS WEBP”

    You must also activate Alter HTML. Did you do that?
    Can I get the URL?

    Sorry I forgot to copy the “as webp” bit 🙂

    It seems to be converting and not breaking images except in chrome when logged into WP. Not sure if that’s a cache issue….

    https://appdacity.com/

    Plugin Author rosell.dk

    (@roselldk)

    I am seeing something strange. The following URL returns HTML:

    view-source:https://appdacity.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2019/08/gearspop-324×160.png.webp

    It appears you are using Shortpixel as well?

    Oh shoot..ok i disabled images in Autoptimize. Seems to load faster but still don’t understand the broken theme files in Chrome only. Weird…

    Plugin Author rosell.dk

    (@roselldk)

    Oh, the reason it returns html is that it is returning a standard 404 not found. So the webp does not exist.

    Can you check the file system if there should be such file?

    You mean if ‘gearspop-324×160.png.webp’ exists on the server?

    Just bought you a coffee 😉

    Plugin Author rosell.dk

    (@roselldk)

    Make sure that “Reference webps that hasn’t been converted yet” is disabled as you haven’t set up any redirection rules that can make that magic happen.

Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.