Support » Plugin: Loco Translate » security warning shown. Why

  • Resolved Lu Is

    (@kalimanmx)


    I received this message after installing the plugin.

    Warning: proc_open() has been disabled for security reasons in /home/+++/public_html/wp-content/plugins/loco-translate/lib/build/shell-compiled.php on line 7

    What can be triggering this?
    Is loco safe?

    http://wordpress.org/plugins/loco-translate/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author timwhitlock

    (@timwhitlock)

    proc_open is used to execute the msgfmt program that compiles MO files and also to look for where it is. It isn’t malicious.

    The next version (and current development version) can do native MO compilation without the need to use proc_open.

    If you want to try it before it’s released as the current version, get it here –
    http://wordpress.org/plugins/loco-translate/developers/
    Then visit the Settings tab and select “Use built-in MO compiler”

    Thanks a lot Tim!
    Great plugin.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘security warning shown. Why’ is closed to new replies.