Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security » Security headers not working

  • Hello Security headers are not working
    we have applied from firewall settings and we did not see any errors during all of the options we are using cache that creates the cache of the page. does it make the problem
    what to do if we want to add those security headers if we add in to .htaccess then it will work and gives error Error parsing header X-XSS-Protection: 1; mode=block, 1 in admin console
    Thanks
    Vikas

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi

    Can you show me the HTTP headers code that you added to your .htaccess?

    You can test your headers by running this command:

    $ curl -I https://YOUR-WEBSITE/index.php
    

    Hello,
    We just added Header always add X-Frame-Options: SAMEORIGIN
    in .htaccess but we have removed it and set those headers from ninjafirewall settings page but it did not work. if we write those headers in .htaccess then it will work
    Thanks
    Vikas

    Plugin Author nintechnet

    (@nintechnet)

    Maybe a conflict with your cache?

    Hello,
    what can be done to implement those headers
    only we need to put in .htaccess
    or with this case does firewall works or not
    Thanks

    Plugin Author nintechnet

    (@nintechnet)

    Keep them in .htaccess if it works, that’s fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.