Support » Plugin: ProfileGrid - User Profiles, Groups and Communities » Security Check Problem on login

  • Resolved reinadepicas

    (@reinadepicas)


    Hello, I like very much this plugin, is fantastic.
    But…no way to avoid the error “security check failed” on login. It happend random, I try to disable the login page cache (I use litespeed plugin) , but it happend again and again.I also try to force logout users for inactivity (20 minutes) , but same error.
    Some trick or solution ? ( at the moment the only way seems to disable the litespeed cache plugin, but it’s not a solution as you can imagine:-) )

    Thanks.
    Regards.

Viewing 5 replies - 1 through 5 (of 5 total)
  • If it works ok when you disable the cache plugin you have to find it over there. I suggest as first try, to make the cache time to live very short and see what happens. If it helps maybe you can disable the cache on the pages where you get the error?

    I’m not from ProfileGrid, but maybe this helps you find out?

    Best regards, Wilfried

    Yes, I’m trying “playing” with litespeed setting, let see…
    I will let you know.
    Thanks.

    Hi @profilegrid0,

    I’m just commenting here as a user of our cache plugin (WP-Optimize) has the same issue.

    FYI, using a nonce field in a login form isn’t necessary (The form on wp-login.php doesn’t use one). Indeed, the nonce fields are used to prevent Cross-site request forgery, and make sure the requests come from the right user. When login in, the username and password play that role.

    So removing the nonce from the login form would make it compatible with cacheing without reducing security.

    Marc.

    At the moment ( already some days…) It seems that exluding the login and registration pages ( profilegrid pages, not WP default login) solve the problem.

    Regards.

    Plugin Support profilegrid0

    (@profilegrid0)

    Hello @reinadepicas, 

    We have noted this issue and will fix this in our upcoming release.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.