Secure URLs

  • zaggstudios


    I’m trying to make a WP site secure, but Recent Facebook Posts seems to use “http://” as a prefix for all URLs (Photos, Link, etc.). I can not seem to find anything obvious to change in the code from a quick glance, but figured I’d check to see if I’m over looking something. Thanks!


Viewing 1 replies (of 1 total)
  • Plugin Author Danny van Kooten



    Linking to a http:// url from a secure site is no problem, no need to change anything there.

    The images / photo’s grabbed from Facebook use a protocol-relative URL so they will automatically switch to https:// if the page is viewed through HTTPS.

    I just took a quick look at what the problem might be then and discovered that the link previews are sometimes in http and sometimes in https. Haven’t figured out yet what caused this.

    Disabling link previews will most likely fix it for now. In the meantime, I’ll try to discover how to work around this.

    PS. You can disable link previews in the widget settings or by passing show_link_previews=0 to the shortcode.

    [recent_facebook_posts show_link_previews=0]

    Hope that helps!

Viewing 1 replies (of 1 total)
  • The topic ‘Secure URLs’ is closed to new replies.
Skip to toolbar