WordPress.org

Forums

secure setup problem (1 post)

  1. dan2604
    Member
    Posted 6 years ago #

    Hi,
    I just installed WP on LAMP, using http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory :

    /var/www/index.php (WP index.php)
    /var/www/wordpress (all the WP files except index.php)

    After that I wanted to secure my setup defining my Apache virtual host this way :

    <VirtualHost *:80>
    DocumentRoot /var/www

    <Directory />
    Order deny,allow
    Deny for all
    DirectoryIndex index.php
    <Files index.php>
    allow from all
    </Files>
    </Directory>

    <Directory /wordpress>
    Options FollowSymLinks
    Order allow,deny
    Allow from all
    </Directory>

    But it doesn't work :

    Forbidden
    You don't have permission to access / on this server.

    If I replace index.php with any index.html, it does work....
    Any idea ?

Topic Closed

This topic has been closed to new replies.

About this Topic