WordPress.org

Support

Support » Plugins and Hacks » Secure Admin plugin causes “You do not have permission….” error

Secure Admin plugin causes “You do not have permission….” error

  • MatthewHSE
    Member

    @matthewhse

    I’m running WordPress 2.0.5 and have an SSL certificate available. I installed the Secure Admin plugin this morning, visited my admin, activated the plugin, and ran into a brick wall.

    Although I can login to the admin now (which *is* using the SSL certificate), any time I try to navigate away from the dashboard, such as to view my profile, add a post, etc., I get the following error message:

    ===================
    You do not have sufficient permissions to access this page.
    ===================

    The HTTP response code is 200, not 302, so it looks like there’s some sort of WordPress authentication issue.

    The user I’m logged in as IS an administrator (actually there *is* only one user) so that wouldn’t seem to be the problem.

    All my file permissions are set to 644. I tried setting the admin file permissions to 755 but that didn’t help anything so I bumped them back down.

    This issue seems to be something that other people have run into, but I haven’t seen a solution. I like the idea of using this plugin instead of the other SSL-on-Admin ideas that I’ve seen posted around, but obviously I can’t use it if I can’t make it work! 😉

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Secure Admin plugin causes “You do not have permission….” error’ is closed to new replies.