Support » Plugin: Genesis Layout Extras - Default Layouts in Genesis for WordPress » Secondary Sidebar outside content wrapper

  • Resolved fresh2012

    (@fresh2012)


    Same issue here…

    My client would like to use the secondary sidebar for their blog page, but it shows up at the bottom outside the content-sidebar-wrap div. I tried registering a sidebar for the blog and it didn’t work. Is this plugin causing those problems? The layout is correct in the page options (first secondary sidebar layout option), but the sidebar is on the bottom left outside the wrapper and skinny. Please help!

    http://www.naturalhairrules.com/blog/

    Thanks!

    Christopher

    https://wordpress.org/plugins/genesis-layout-extras/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author David Decker

    (@daveshine)

    @fresh2012:
    Hi Christopher,
    Thanks for your feedback!

    I am sorry, but what do you mean with “Same issue here…”? Did you already have a support request or anything else?

    I had a look at the URL you provided above, and saw you’re using one of my additional layouts “Content / Sidebar-Alt” but no additional styling from my plugin is loaded.

    You should enable the option “Load CSS styles for the two 2-column layouts?” in my plugin options and then you should be fine 🙂

    I hope that helps, Dave 🙂

    fresh2012

    (@fresh2012)

    Thanks so much for the prompt response!

    I enabled the option but it’s still at the bottom of the page and loading outside the content-sidebar-wrap div. Is it a caching issue? WP Super Cache isn’t active either, so I don’t know what the issue is. Anything else you can suggest?

    fresh2012

    (@fresh2012)

    PS: The “same thing here” is a remnant from a reply that I was going to leave on another support issue. Please disregard that line. Thanks!

    Plugin Author David Decker

    (@daveshine)

    You’re welcome 🙂

    I took a look again, the source code of your front page says it is cached, so at least I see the cached version — and this currently has not my style loaded, but I assume it’s the caching…

    Also, since you’re using the Metro Pro theme, it has a filter by default for the front page template. You have to manually uncomment it, sorry, but there’s no other alternative to this!

    Go in your child theme folder, make file backup of “front-page.php”, and then look for this line:

    // Force content-sidebar layout setting
    add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_content_sidebar' );

    and change to that:

    // Force content-sidebar layout setting
    //add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_content_sidebar' );

    This will disable that filter and instead give the chance layout setting of my plugin can be applied 🙂

    Good luck, Dave 🙂

    fresh2012

    (@fresh2012)

    BOOM!!!!

    Wow..

    Thank you SO much, David!! I never would’ve figured this out on my own. Thanks so, so much!!!

    Where do I donate? 🙂

    Christopher

    Plugin Author David Decker

    (@daveshine)

    Hi Christopher!

    Thanks! Glad it’s working for you, awesome! 🙂

    Yeah, if you want to donate, here’s a little page for that: http://genesisthemes.de/en/donate/

    Thanks in advance!!

    –Dave 🙂

    fresh2012

    (@fresh2012)

    One last thing.. Where do I change the width of the sidebar? I tried changing the sidebar-alt width but it kicks down below the content. If you have a suggestion on this it will help as well. Thanks again! CB

    Plugin Author David Decker

    (@daveshine)

    Hi!

    Yeah, that’s possible with CSS — since this is now loaded via my plugin (only some tweaks for those new layouts), you have to use “!important” if you want to override that.

    In your case, you can use those classes/ values — the following is the plugin’s default, just change the percentage values to your liking. Please reserve about 4-5% for spacing between those containers, just experiment. The defaults sum up to 96% which keeps the floating and enough space between.

    This would be the global default:

    /* Sidebar-Alt */
    .content-sidebaralt #sidebar-alt,
    .sidebaralt-content #sidebar-alt {
    	width: 19% !important;
    }
    
    /* Content-Sidebar Wrapper */
    .content-sidebaralt #content-sidebar-wrap,
    .sidebaralt-content #content-sidebar-wrap {
    	width: 77% !important;
    }

    If only used for the home page / front page, then add the body class before, like so:

    /* Sidebar-Alt */
    .home .content-sidebaralt #sidebar-alt,
    .home .sidebaralt-content #sidebar-alt {
    	width: 19% !important;
    }
    
    /* Content-Sidebar Wrapper */
    .home .content-sidebaralt #content-sidebar-wrap,
    .home .sidebaralt-content #content-sidebar-wrap {
    	width: 77% !important;
    }

    All these tweaks go into your child theme’s style.css file (make file backup before at best). Just before the “Responsive” section there.

    If you want to tweak the responsive rules from my plugin, have a look into my plugin’s sub folder “/css/” and there the file “gle-layout-2col-styles.css” with all the used rules for that layout option.

    Good luck!

    –Dave 🙂

    fresh2012

    (@fresh2012)

    I should’ve known that.. Thanks again and hope you got the donation! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Secondary Sidebar outside content wrapper’ is closed to new replies.