Support » Plugins and Hacks » secondary language [plugin: wptouch]

  • Hi,
    I just installed wptouch and it works pretty much perfectly on my primary language, but not on my secondary language, which runs on a different domain through WPML.
    If I click on a page from within the menu that points to the secondary language it shows up in my secondary language and from there I can get posts as well, but if I type the domain for the secondary language directly I get the standard WP theme.
    Any ideas how to solve this?
    Also, although I made a translation and uploaded it into the lang folder of wptouch only some of the strings show up translated and it doesn’t even match the translation I did. Weird… It would be nice to be able to display the language switcher on the mobile theme.
    Any help with this would be appreciated.

    My primary language’s domain is and the secondary is


Viewing 3 replies - 1 through 3 (of 3 total)
  • BraveNewCode Inc.



    Support for WPML is on-going. However, if you’re seeing the standard WP theme when accessing your website on a supported mobile device it usually means there is a cache issue.

    I see that you are running Quick Cache, so please add the list of WPtouch’s mobile user agents to the user agents to ignore in Quick Cache settings.

    The list can be found in the WPtouch admin panel.



    Thanks for your reply.
    Since I made the above comment I had to disable wptouch as I started having issues with the mobile theme showing up when browsing on my desktop.
    Do you think it could have been caused by the cashing plugin as well?

    BraveNewCode Inc.


    Do you think it could have been caused by the cashing plugin as well?

    Yes, especially if it wasn’t specifically configured per the instructions above.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘secondary language [plugin: wptouch]’ is closed to new replies.