WordPress.org

Support

Support » How-To and Troubleshooting » Second Post…. Comments not working

Second Post…. Comments not working

  • Hello,

    I just upgraded my installation to 1.5.1 and when I click on the comments link, it just shows the individual archive with no form to post comments.

    I have searched the forums and I have not been able to find an answer for this. I tried replacing my comments.php page with the one from the Kubrick and the default theme to no avail.

    If it helps, my URL is http://www.firewatching.com/ray/blog

    I am using the Kubrick theme as a base for my theme.

    Thanks in advance…

    Ray

Viewing 15 replies - 1 through 15 (of 16 total)
  • in your single.php file, add this line:

    <?php comments_template(); ?>

    It calls the comments.php file/template

    Not sure, but try fixing the couple of validation errors first, then maybe something will show up in the source.

    I don’t see a single.php file… do you mean index.php?

    you can edit single.php in the admin panel at Presentation -> Theme Editor -> [your theme] -> Post Template.

    Oh – I don’t have a post template (no single.php) in my theme – I’m using Kubrick.

    Does that matter?

    Unless you deleted some of the files, kubrick does come with a single.php and your site is using the single.php file because your individual post pages are different from your index page.

    It will be in: /wp-content/themes/{theme_name}/single.php

    Add the code I posted above just above the “endwhile” statement.

    I looked and I didn’t have a single.php in my theme – apparently I didn’t need one in 1.2.1 in order for comments to work on my template. But this stopped working when I upgraded…

    So I copied the single.php from Kubrick into my theme and it still doesn’t work. I verified that the code you pasted is in there…

    When I use the default kubrick theme in 1.5, I get a comments form, but it’s only a text area, not the full comments form that includes name, email, url, etc.

    If you look at my site now, you can see it with the single.php copied unchanged from the Kubrick template. Comments are still not showing up…

    Thanks,

    Ray

    When using the default theme, did it show “Logged in as .” over the text area? If so, check your users list and make sure there is no blank one.

    Your single.php doesn’t seem to be right, since you’re not getting your header either.

    I checked and it does say “logged in as” for my name. I had another user with the same nickname but no first and last name so it must have been created when I imported from my MT blog.

    I agree on the problem with single.php but I don’t know why it doesn’t work because I just copy-pasted from the default theme into my own… Any ideas?

    I may be having some similar situation.

    http://www.trepryor.com/

    Comment links show up, but when you click, you get no form. I’m baffled.

    If your current theme came from 1.2, and you getting other files from 1.5, you’re probably missing the header.php and footer.php. The 1.5 single.php pulls the header and footer from separate files, whereas the old kubrick was just one index.php file.

    You’ll either have to edit the 1.5 kubrick header and footer files, or create your own header.php and footer.php from your (old) 1.2->1.5 index.php

    OR…remove <?php get_header(); ?> and <?php get_footer(); ?> from the single.php and add your header and footer code in their respective places.

    And the other problem is I’m still not getting the comments form when I use the single.php in my theme…

    Also, in the default Kubrick template, the comments form is a single text area. It used to be the full comments form with name, email, url, and message. Is there some option to make all these fields show up? Or is there another version of the kubrick template that has these?

    “Is there some option to make all these fields show up?”

    Yes. Log out.

    But I’m still not getting the comments form when I use the kubrick single.php in my theme..

    Any ideas?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Second Post…. Comments not working’ is closed to new replies.
Skip to toolbar