Support » Fixing WordPress » search_engine_friendly_urls

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Matt Mullenweg



    Very much so.

    FWIW, you can re-enable it. Here’s what you need to do:
    1) Get the ‘archives’ file from an old b2 install – make sure it references your index.php, and change the reference to ‘b2config.php’ to ‘wp-config.php’
    2) Rename the example.htaccess to .htaccess
    3) Remove the reference to ‘$siteurl’ in b2-include/b2template.functions.php
    4) Change your siteurl variable in the control panel to be /archives instead of /index.php
    This’ll at least make permalinks which are the same as the hacked-in version we used to have, and links that are something like /p/101 should work too.

    It has been removed from the install and upgrade scripts in CVS. That will be in the next release.
    If you have already applied those scripts and have this option. I gues by now you know not to turn it on.
    I could provide an update script to remove this option (and use_preview which also doesn’t work) if people really need it.

    By the way bdjohns1, there are a few more things you need to do to get full functionality (I’ve hacked it in on my site to make sure my old permalinks are still permanent) but there are a couple of places which just don’t work (next and prev in paged output for one). But we will be implementing a better scheme.

    Yeah, what I did was go ahead and use unfriendly URLs for now, but I did install the ‘archives’ file, so it will actually display the entry (albeit with links that are kinda funny) as opposed to giving the user a 404 error.
    I’m thinking what I might do is rewrite the ‘archives’ file so that it takes a “friendly” url like /archives/37 and redirects to /index.php?p=37&c=1 or something like that.
    That way, I can hide WP’s implementation and present whatever permalink scheme I like. (possibly, I’d need to write custom permalink-generating template functions). Fortunately, I don’t have too many people linking direct to articles on my site, so I can still change it to however I want.

    Is this currently in .72 gold?

    how do friendly urls handle categories?

    Moderator Matt Mullenweg



    search_engine_friendly_urls was removed from .72 because its functionality was limited, its name deceptive, and it broke several things.

    oh, it is still in the menu in my .72?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘search_engine_friendly_urls’ is closed to new replies.