Support » Themes and Templates » Search results page pagination leading to 404 error

  • When I search for anything with more than one word (i.e. “the dog”), the search results page displays the first page fine, but if I try to go to page 2 or higher, I get a 404 error. I noticed that in the URL, it doesn’t put the + in between the search words. However, if I add the + manually, I can view all pages of the search results fine.

    So, this gives me a 404 error:
    But this displays the content fine:

    How do I get it to add the plus symbol (+) into the URL?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator keesiemeijer


    Are you using a plugin for your search results pages. I think the normal url for a search is like this:

    No, I’m not using a plugin. I am using a WooThemes theme though, so I’m not sure if that affects anything.

    The URL of the first page looks like this:

    But when I click page 2, it looks like this:

    Moderator keesiemeijer


    If it’s not a plugin it must be the theme. Normally you would get urls similar to this on paginated search results:

    Something is rewriting the search pages url to /search/…

    Since this is a probably commercial theme with its own functionality and support system, I recommend you contact the theme developer for assistance.

    Ok, well that sucks. Unfortunately I don’t have a login to their support system.

    Any idea what template I should look in to edit the code?

    Moderator keesiemeijer


    Just to be sure it’s the theme that rewrites the url switch to the default (twentyeleven) theme and see if it still happens.

    Other than that, I would suggest you buy the theme so you can get support for it.

    I did something which I think is similar to what you suggested. I replaced the Woo Search widget with another one called Advanced Search Widget. When I did the search, I had the exact same problem…pages 2 and up return a 404. Page 1 worked, but looked like this:

    Could the issue be related to the pagination code?

    Moderator keesiemeijer


    Could the issue be related to the pagination code?

    Yes it could, but we have no access to the theme files so we can’t troubleshoot it. Do you have the same issue when you switch to the default theme?

    I am so afraid to switch themes, then switch back. I have edited so many theme files. Will everything return to normal if I do this?

    I thought I would reply as I’m experiencing the same issue, my client reported it today. I’m using WooStore with WooCommerce.

    The ampersand is lost within the URL string for subsequent results pages which joins the two words together and thereby leads to a 404.

    I do however have access to their support and I’ve raised a ticket. I’ve already disabled all plugins (except woocommerce) and also tried a fresh up-to-date version of the theme and no luck. Equally, installing alternative search plugins doesn’t help either as they (Swiftype & Relevant Search) don’t seem to be compatible with the theme at all.

    I’ll wait for Woothemes to come back to me and I’ll make a post here for any others experiencing the same issue or finding the thread while looking for answers as I have now!

    I’m having this exact same problem – WooThemes Canvas – I’ll log in to that support area and see what I find.

    I received an email from Woothemes support on 29th October suggesting that there would be a framework update available by the end of October.

    It’s now the 5th November and having just checked, there doesn’t appear to be a new framework available.


    I’ve asked for an update and I’ll update you guys when I have one…

    Wooframework 5.5.0 has just been released, I’ve updated my theme and pagination of multiple worded search results is working once again 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Search results page pagination leading to 404 error’ is closed to new replies.