Support » Plugin: Yoast SEO » Search results not showing my text

  • Resolved Rico

    (@nascas)


    Hi,

    I have noticed on several sites which have been active for at least 6 months that when using Google search I’m not getting the text I inserted in Yoast plugin (and can be also seen in the snippet preview).
    I’m sure I have missed something, or?

    Thanks,
    R

    • This topic was modified 8 months, 1 week ago by  Rico.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support devnihil

    (@devnihil)

    Can you please provide us with an example URL of a page where you are experiencing this issue?

    Also, whereas Google typically uses the meta description from the metadata for indexing, this is not always the case. Google will sometimes modify or ignore the meta description when it sees fit. This is not due to the plugin not functioning as expected, but rather is due to Google using another value for the meta description it indexes as it’s algorithm has concluded that there is a better version to index. We have additional information on this here: https://kb.yoast.com/kb/my-meta-descriptions-arent-showing-up-in-the-search-result-pages/. If Google is ignoring the meta description you have created for a page and creating it’s own description based off the page’s content, we would recommend creating a new meta description that reflect’s the page’s content. We have an article on how to write clean and meaningful meta description for your pages and posts by following the steps given in this guide. https://yoast.com/meta-descriptions/.

    Rico

    (@nascas)

    Hi,
    thank you for your reply.
    Here: https://bit.ly/2W0HkBQ
    I’m quite familiar with your plugin and have been using it regularly. And quite successfully since I’m getting very good results. But there are two or three sites where there is no snippet information.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We can see that Yoast is showing the right title and description in the source code. See image: https://pasteboard.co/I69hSWK.png

    However, we can see Google is not showing the right title here. See image: https://pasteboard.co/I69hX3L.png

    To resolve the issue we suggest two options:

    1. Can you confirm if you use Fetch as Googlebot that the issue is resolved? This will force Google to update the index. You may need to use it several times. This guide explains more: https://kb.yoast.com/kb/fetch-as-googlebot/.

    2. If that does not work, it means Google is changing your title because it thinks it knows a better title to show your audience. This guide explains more: https://kb.yoast.com/kb/google-shows-different-titles-for-my-site/#ignored

    Hi,
    Thank you.
    I will give it a try!
    By the way, I’m getting this when searching with google:
    http://shrani.si/f/1K/IB/2gZqsLFj/pe.jpg

    Plugin Support amboutwe

    (@amboutwe)

    http://shrani.si/f/1K/IB/2gZqsLFj/pe.jpg

    The screenshot shows that the search critera included the term velenje which means Google scans the index for that exact phrase. Google uses the search term to highlight information in search results which is why the description is different than what you entered into the plugin.

    In this case, the search term is not in the meta description you wrote so Google uses content from the page to create a custom description.

    Due to this being handled on Google’s end, there is little you can do to force Google to display the preferred description. The best advice I can provide, unfortunately, is to try a different description. This article provides advice on creating the right description for your site.

    Plugin Support jerparx

    (@jerparx)

    Closed. No further questions.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Search results not showing my text’ is closed to new replies.