Support » Plugin: Yoast SEO » Search page's Canonical URL's giving soft 404 errors

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter rks2286

    (@rks2286)

    Please help!!

    Don’t worry about soft 404 errors and maybe noindex search results or block in a robots file

    Actually you have <meta name="robots" content="noindex,follow"/>

    so don’t worry
    https://support.google.com/webmasters/answer/181708

    Try saving the Permalinks again.

    Thread Starter rks2286

    (@rks2286)

    Yes i have the meta noindex,follow but just wanted to know how to correct the canonical urls for the search or enable the urls “search/page/65/” to work like “?s&paged=65” which works fine.

    You error is a error. So wanted things to be clean as much as possible. 🙂

    Any other suggestions much appreciated ..

    Thanks

    Thread Starter rks2286

    (@rks2286)

    I have put something like below in my robots.txt is it a good idea or bad one?

    User-agent: Googlebot
    Allow: /
    Allow: /category/*/*
    Disallow:/search/*/*

    I would remove all the Allow as by default it is allowed unless you use a disallow.

    User-agent: *
    Disallow:
    Disallow: /*?s=*

    ETC

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Search page's Canonical URL's giving soft 404 errors’ is closed to new replies.