WordPress.org

Forums

Search Page CSS Issue (3 posts)

  1. symbiose
    Member
    Posted 1 year ago #

    I can't find in the code why this mess is happening with the submenu bar here: http://www.iropartners.at/?s=nofindinput when entering a search term, which can't be found on the page.

    THEME SEARCH.PHP CODE_

    <?php get_header(); ?>
    
    	<div class="content">
    
    	<?php if (have_posts()) : ?>
    
    		<h2>Ihre Such - Resultate f&uuml;r ‘<?php the_search_query(); ?>’</h2>
    
            <br />
    
            	<div class="searchbox"><?php include (TEMPLATEPATH . '/searchform.php'); ?></div>
    
            <br /><br />
    
    		<div class="navigation">
    			<div class="alignleft"><?php next_posts_link('&laquo; Older Entries') ?></div>
    			<div class="alignright"><?php previous_posts_link('Newer Entries &raquo;') ?></div>
    		</div>
    
    		<?php while (have_posts()) : the_post(); ?>
    
    			<div class="post" id="post-<?php the_ID(); ?>">
    				<h3 class="post-title"><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h3>
    
    				<div class="entry">
    					<?php the_excerpt(); ?>
    				</div>
    
    				<div class="postmetadata">
    				<?php if( function_exists('the_tags') )
    						the_tags(__('Tags: '), ', ', '<br />');
    				?><br />
    			  <?php edit_post_link('Edit', '', ' | '); ?><a href="<?php the_permalink() ?>" title="Permanent Link to <?php the_title_attribute(); ?>"><strong>Lesen Sie mehr ...</strong></a></div>
    			</div>
    
    		<?php endwhile; ?>
    
    		<div class="navigation">
    			<div class="alignleft"><?php next_posts_link('&laquo; Older Entries') ?></div>
    			<div class="alignright"><?php previous_posts_link('Newer Entries &raquo;') ?></div>
    		</div>
    
    	<?php else : ?>
    
    		<h2>Wir haben leider keine Eintr&auml;ge f&uuml;r Sie gefunden. Probieren Sie eine andere Eingabe?</h2>
    
    	<?php endif; ?>
    
    </div>
    
    <?php get_sidebar(); ?>
    
    <?php get_footer(); ?>

    Thanks!

  2. kaniamea
    Member
    Posted 1 year ago #

    Hello, did you do any modifications to your search.php page? If not, download the theme again and re-upload search.php file to your theme folder.

  3. symbiose
    Member
    Posted 1 year ago #

    Hi, not really. But maybe I have a bug in the submenu code (header.php) ?:

    <div class="submenu">
    
      <?php
      if($post->post_parent)
      $children = wp_list_pages("title_li=&child_of=".$post->post_parent."&echo=0");
      else
      $children = wp_list_pages("title_li=&child_of=".$post->ID."&echo=0");
      if ($children) { ?>
    
      <ul class="submenu_items">
      	<?php echo $children; ?>
      </ul>
    
      <?php } ?>
    
    </div>

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.