Support » Plugin: WP Custom Fields Search » Search not working

  • Your plugin is great but the search is not working. I have disabled all the plugins also switch back to twenty sixteen themes but the search is not working. May I know how to fix it?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author don benjamin

    (@dondon-benjamincouk)

    Hi @csesalmen93,

    Sorry for the slow reply. What exactly is happening? Are you seeing error messages? Or simply not getting results?

    If you’re seeing error messages these may help to track down the issue.

    If you are not seeing results, please try removing all the search fields and then re-adding one by one to see which is causing the problem.

    Thanks,
    Don

    I am getting the error result not found. I have disabled all the plugins did other things that are in instructions. It seems not only me but everyone is having a problem with this plugin. It just simply doesn’t work.

    I’m having a similar problem. Using WP V4.9.8, no other plugins. I can create a search form with categories and tags to select from, but when I click on the “Select” button, if I have not selected anything I get a partial screen with the message “Click to Continue”. Click then takes you back to the home page. If I select any category or tag and click on “Select”, some error messages flash up saying “no such item” or something to that effect, then the page goes black. Removing the search fields made no difference.

    Further to my previous report, these are some of the error messages I get:
    Trying to get property of non-object in <b>/var/www/html/wp-includes/comment-template.php</b> on line <b>1196</b>
    Trying to get property of non-object in <b>/var/www/html/wp-includes/comment-template.php</b> on line <b>1222</b>
    Trying to get property of non-object in <b>/var/www/html/wp-includes/general-template.php</b> on line <b>2711</b>
    I’m using the TwentySixteen theme.
    When I clisk “Search” without making any selections, I see “Search Results for:”, then a bit of my home page followed by “Continue Reading” as a link that takes me back to the home page.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Search not working’ is closed to new replies.