WordPress.org

Support

Support » Themes and Templates » Search issue

Search issue

  • mvanboordt

    @mvanboordt

    Hi,

    I have a little problem with my search function.

    It works. Except when a user clicks on the search button without filling in the form.

    In the address bar I see the following:
    http://www.xxx.nl/themename/?submit.x=12&submit.y=15&s=

    I have no idea what the x and y values are and I can’t seem to find them anywhere in the code.
    The s value is the value typed in the form.

    Any other way works. If I fill out the form with content that can be found it shows the content and if I fill in the form with content that can’t be found it shows a message that the content can’t be found.

    I based the search function upon the twenty eleven templates.

    I hope anybody can help me with this.

    M.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Andrew Nevins

    @anevins

    Forum moderator

    Which theme are you using?

    mvanboordt

    @mvanboordt

    I create my own theme.

    mvanboordt

    @mvanboordt

    I forgot to mention what happens.

    If the user clicks the search button without the form filled in the page that is loaded is based upon my default template and shows all pages that are listed in the upper level from the website.

    However I told the search-template to use a different template. So it looks like it makes a combination of the two templates.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Search issue’ is closed to new replies.
Skip to toolbar