Support » Plugin: Autoptimize » Search icon not working

  • Resolved hbk747

    (@hbk747)


    Hello,

    Hope you are well.

    I upgraded to the latest version of the plugin on my staging website and for some reason, the search icon on the top left of the website does not work. Usually, when you click the search (magnifying glass) icon, a curtain descends and a search bar appears. Plus on the mobile version of the website, the top menu disappears on certain pages. I talked to my theme developer, he said it could be a jquery error (but he isn’t much help, unfortunately). I hope you know what is going on. I even tried adding my theme in Async Javascripts settings but it did not work. If you need my staging credentials, let me know.

    P.S. I left a 5 star review because of the last problem of mine you fixed πŸ™‚

    Edit: And the weird thing is sometimes it starts working and sometimes it stops. For example right now I am checking and on Brave/Chrome the search icon does not work while on Firefox it is working. Very weird.

    • This topic was modified 9 months, 1 week ago by hbk747.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hey hbk747;
    I’ve tried in both FF & Chrome (both desktop & on android) and can’t seem to reproduce. Can you try again in an anonymous (private) browser window to see if you have the same issue there?

    frank

    Thread Starter hbk747

    (@hbk747)

    @optimizingmatters

    Yes, it still does not work. Clearing the cache or using a private window.

    https://wordpress-601622-2096305.cloudwaysapps.com/

    So basically when I try to click this button, the search bar does not pop up. I have marked the icon below.

    https://ibb.co/J5SmfNm

    For me, and my wife it is not working on android or laptop. I cannot figure it out. This is why I have not updated the 4 plugins that could be causing on my live site.

    1) AUtoptimize 2) Relevanssi 3) SIte Kit 4) Redux

    I have messaged Relevanssi and they say it is unrelated to them. Redux has not replied. Now I am talking to you.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, let’s try to identify what is breaking things by just disabling CSS or JS or HTML or Image optimization (incl. lazyload). Based on that we can see what the next steps need to be πŸ™‚

    frank

    Thread Starter hbk747

    (@hbk747)

    Thanks Frank.

    I will get back to you πŸ™‚

    Thread Starter hbk747

    (@hbk747)

    @optimizingmatters

    I tried deactivating them all and it did not solve anything. Image optimization I did not have turned on – I am using SPAI.

    πŸ™

    Edit: I think I fixed it. It was Wp Rocket and their “remove unused css (beta)”.

    Thanks for your help!

    Take care Frank!

    • This reply was modified 9 months, 1 week ago by hbk747.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I think I fixed it. It was Wp Rocket and their β€œremove unused css (beta)”.

    that makes sense, I did indeed not find the LYTE css when wp rocket was active. good to know! πŸ™‚

    Thanks for your help!

    you’re welcome, feel free to leave a review of the plugin and support here! πŸ™‚

    enjoy your weekend!
    frank

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Search icon not working’ is closed to new replies.