Support » Fixing WordPress » Search form deleted by addig a post?! How so?

  • I’ve spent all day trying to get rid of the search form in right hand sidebar of a theme. I’ve been using Starkers theme (latest version). I seem to have deleted it BUT had to add a post first! – read that somewhere here. How on earth does that work? Anyone shed some light on this please??!

    Thanks in advance,
    Confused Andrew

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    (@esmi)

    Forum Moderator

    The cache needed updating – either at your browser’s end or at your web hosts/ISP?

    I’m just a new newbie with WordPress. Nothing to do with my webhost/ISP. WordPress is saved locally.

    Furthermore, I just deleted the post and now the form appears again.

    “Not Found
    Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.
    Search for: “

    the above appears along with the search field.

    Anyone throw any light upo this for me?

    esmi

    (@esmi)

    Forum Moderator

    Have you tried adding an empty text widget to your sidebar? Or editing your theme’s sidebar.php template file?

    I’ve no knowledge of php but I’ve been editing the sidebar.php and a host of other php files all day.

    How do I ad an empty Text widget then esmi?

    esmi

    (@esmi)

    Forum Moderator

    If your theme is widget aware, you should be to just drop a text widget into the sidebar via Appearance -> Widgets

    I’ll check it out. Cheers esmi for the helpful thoughts.

    ok, so I got rid of the post. The search bar appeared with the above text again. So then I drag and droppped a text widget via backend, Appearance -> Widgets.

    Text Widget didn’t work! Damn.

    Any of thoughts?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Search form deleted by addig a post?! How so?’ is closed to new replies.