Support » Plugin: WP Knowledgebase » Search feature returning Sorry, no posts were found

  • I have been producing blog posts like crazy lately because a few months ago I noticed I wasn’t in any search results for the keywords I was targeting. Then today I did an all in title or all in url search for my exact blog post URL only to find no websites in the world have that URL which is impossible because I have a blog post with it. Then I did a search from my home page for the word “alaska” & the word “trover” which I know two of my oldest posts have and my site said,

    Sorry, no posts were found

    Does anybody have any idea how to fix this or what to look at to fix this?? My site is aowanders.com

    and if you do a title search on google or an exact URL search on google for

    trover could be the death of the travel industry only one result shows up, and that is from medium when I shared my post to the platform the day I created it. Any help or suggestions would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Blake

    (@alexanderblake)

    As far as the knowledgebase is concerned, I had no problem searching your site and coming up with results. I actually don’t know why you would use it if all you’re writing are blogs and articles for your main WP site. They overlap too much.

    As far as your SEO and search-engine-index results are concerned, I would up your on-page SEO with Yoast. I see you already have it installed, so I’m not sure how you could be experiencing errors. The source code shows all the descriptions, key phrases, ALT tags, and links… so you’re on the right track.

    It’s been 2 weeks, so maybe this was a short-term issue. Has it been resolved for you?

    Yeah I installed a different search plugin and finally got Google to index my site.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Search feature returning Sorry, no posts were found’ is closed to new replies.