Support » Plugin: AMP for WP - Accelerated Mobile Pages » Search Console Warning – Image size smaller than recommended size

  • Resolved havig

    (@havig)


    Hi guys!

    I know that there are new guidelines for images but what are we supposed to do here?

    There’s no way I will manually change all my images to 1200px wide (especially when they are taller for Pinterest reasons) and also because they will be heavy as heck.

    I could change one of the AMP content images (not the one that is displayed on the non-AMP version) but would that make a difference?

    What do you recommend we do?

    Thank you so much!!

    Havi

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 46 total)
  • Hello, Just wanted to ask the authors if setting the Default Post Image Width to 1200 and Default Post Image Height to 675 will fix this issue? This option is found in Structured Data settings of the AMP plugin. Please let us know

    Correct, guys. It’s not the plugin error. That’s why I only asked for a recommendation from the developers. Maybe they know what we should do.

    Also, it’s not de-indexing the AMP pages… just a warning that we cannot show on the carousels (bummer)

    @bostonstrippers you set such a huge featured image and checked the markup and it wasn’t 1200px wide?

    I am with @robbo55 here… is there a trick that could be implemented? ๐Ÿ˜‰

    Google went nuts!!

    “Images should be at least 1200 pixels wide.” – I believe this is not something we can trick or get around, especially as it also states: “Every page must contain at least one image” https://developers.google.com/search/docs/data-types/article#article_types

    If you include an image which is wider than 1200px, it should validate.

    Not sure why images should be so large for mobile web, but am sure there will be some reasoning somewhere. Probably worth exploring ways to comply easily with this – for example, setting a “default” featured image which is 1200px wide to be applied in cases where there are non relevant in the post?

    But note the rule “Only a marked-up image that directly belongs to the article should be specified.” so potentially it looks like making the images larger will be the only long term solution to remove this warning.

    • This reply was modified 1 year, 2 months ago by robscott. Reason: additional detail I missed before

    I am thinking it’s not really the width of the image but the number of pixels (so high-res will impact as well)

    I noticed a post that was 564×846 and it passed but I had not compressed the image as I usually do.

    This goes against everything they have been preaching so far… a faster internet. Maybe Google is playing a prank on all of us.

    I am definitely not going to increase/change the size of all my featured images for AMP. That’s crazy!! ๐Ÿ˜‰

    I found it… but it doesn’t start out with anything about images… Where does the featured image live, so to speak, in AmpforWP ????

    I take it you have images for your AMP pages that are separate from your desktop images…???

    @considerthis1 you are 100% correct. All your Featured images “live” in the WordPress Featured image field (as determined by your theme as well)
    If you make that image a 1200px wide, it will directly impact your desktop and mobile versions (unless you use the AMP version for mobile and/or desktop)

    @jwbats you CSS is very handy – but I don’t know if it’s needed. To avoid showing a Featured image at the top of your AMP page all you have to do is go to AMP > Design > Single Page > Disable Feature Image on the Single Elements section

    Everybody: this is not a plugin problem – it’s a new Google requirement to show up on Carousels, etc. If you don’t need that, you do not need to comply.

    Question: Does anybody know if the AMP plugin allows you to choose a different featured image than the one selected for the Desktop version? If so, could you please share how? (If not, is it possible we request the plugin developers to create this functionality? They are great and I’m sure they are already thinking of something that can be of help – also I wish they would shed some light and guidance for us on this issue)

    I think you’re understanding of the problem/situation is right on target. I’ll do do that now. re, single page.

    As an aside, did your views drop dramatically today? or is it just me. My most viewed page has gone from 250 views yesterday at this time, to 25 today. ๐Ÿ™

    Oh dear… I’m not finding that setting under Design – Single Page…

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi all,

    Sorry for the delay in response.

    First of all, this is just a WARNING. It is NOT an error. AMP pages are still indexed and displayed in Googleโ€™s search results. However, they are marked as less than perfect pages, because they contain images which are less than 1200 pixels wide. And This is not a plugin problem, itโ€™s a new Google requirement to show up on Google Search Carousels.

    According to Google, Below are the Image required properties:

    * Images should be at least 1200 pixels wide.
    * Every page must contain at least one image (whether or not you include markup). Google will pick the best image to display in Search results based on the aspect ratio and resolution, etc.

    You can read more from here: https://developers.google.com/search/docs/data-types/article#article_types

    Screenshot: http://take.ms/T7FJT

    Coming to the solution, We’re still trying to figure out how to fix permanently without changing the existing featured image. The temporary solution is, when you’re publishing the new post, please set the featured image should be at least 1200 pixels wide so that Google can show the new posts in Carousels.

    Hope it helps.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @jwbats,

    When you select the theme as a Swift theme, that option will visible.

    Hope it helps.

    @domdomdomdom That’s correct, but it still solves the problem of having an ugly-ass 1200 pixel wide image at the top of your AMP pages.

    Wide images are usually also higher. Unless you’re wanting to upload panorama pictures.

    1200 Pixel wide images are exactly what I’m talking about, mate.

    I’ve already resized mine and turned off featured image display at the top of AMP. My problem is solved already.

    Hi everybody!

    Thank you @ampforwp for letting us know you are working on a way to deal with Google’s NEW request.

    Here’s what I found and hopefully it will be useful for you:

    1- the image does NOT have to be 1200 wide, it CAN be 1200 tall (for those that may have both image styles)

    2- The validation check fails if you have AMP Categories enabled (at least my wordpress categories do not have a featured image) and Search Console does not validate the rest of the fixed AMP pages.

    Here is an example: https://argen-travel.com/category/northwest/amp/

    I think the only way to have this validation go through is to disable Post Categories in AMP.

    3- Even though Google states that you may have another image with these dimensions inside of the post, it is not true that it will validate the page and consider it for the AMP carousel.

    I tried adding a 1200px wide image to the Custom AMP field without changing the thumbnail and it failed.

    That’s all for now! Please keep everybody posted of your progress!

    Thank you!

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Search Console Warning – Image size smaller than recommended size’ is closed to new replies.