Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Search Console data is not yet available – 3mos

  • Resolved bry0sb

    (@bry0sb)


    Greetings, Search Console data is not yet available for past couple of months. 3-4 months ago had an issue with yoast seo regarding sitemap, turned off that feature and went with Google XML Sitemaps. Have no crawl errors and sitemap fetched ok. prior to that the site had 8 posts that were ranked number 1 in results, I’m now down to a couple and finally doing something about it lol.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Renee Johnson

    (@reneesoffice)

    @bry0sb thanks for reaching out!

    Could you provide your Site Health information here or through this form?

    This includes Site Kit specific information that we can check about the service connections on your site.

    Thread Starter bry0sb

    (@bry0sb)

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: en_US
    user_language: en_US
    timezone: America/Los_Angeles
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 1
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 203
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home4/bimmersc/public_html
    wordpress_size: 3.80 GB (4084065094 bytes)
    uploads_path: /home4/bimmersc/public_html/wp-content/uploads
    uploads_size: 337.87 MB (354282790 bytes)
    themes_path: /home4/bimmersc/public_html/wp-content/themes
    themes_size: 5.75 MB (6031984 bytes)
    plugins_path: /home4/bimmersc/public_html/wp-content/plugins
    plugins_size: 145.96 MB (153054890 bytes)
    database_size: 15.73 MB (16493126 bytes)
    total_size: 4.30 GB (4613927884 bytes)
    
    ### wp-dropins (2) ###
    
    advanced-cache.php: true
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: Attitude Pro (attitude-pro)
    version: 3.0.7
    author: Theme Horse
    author_website: https://www.themehorse.com
    parent_theme: none
    theme_features: core-block-patterns, menus, automatic-feed-links, title-tag, post-thumbnails, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, custom-background, custom-header, editor-style, woocommerce, widgets
    theme_path: /home4/bimmersc/public_html/wp-content/themes/attitude-pro
    auto_update: Disabled
    
    ### wp-themes-inactive (2) ###
    
    Attitude: version: 4.0.3, author: Theme Horse,Auto-updates disabled
    Twenty Twenty: version: 1.5, author: the WordPress team,Auto-updates disabled
    
    ### wp-mu-plugins (4) ###
    
    Endurance Browser Cache: version: 0.4, author: Mike Hansen
    Endurance Page Cache: version: 2.0.2, author: Mike Hansen
    Endurance PHP Edge: version: 0.2, author: Mike Hansen
    SSO: version: 0.3, author: Garth Mortensen, Mike Hansen
    
    ### wp-plugins-active (27) ###
    
    All 404 Redirect to Homepage: version: 1.20, author: Fakhri Alsadi, Auto-updates disabled
    Autoptimize: version: 2.7.7, author: Frank Goossens (futtta), Auto-updates disabled
    Broken Link Checker: version: 1.11.14, author: WPMU DEV, Auto-updates disabled
    Coupon Codes: version: 1.2.1, author: Norbert Dreszer, Auto-updates disabled
    Disable Author Archives: version: 1.2.1, author: freemp, Auto-updates disabled
    Disable Comments: version: 1.11.0, author: WPDeveloper, Auto-updates disabled
    eCommerce Product Catalog for WordPress: version: 3.0, author: impleCode, Auto-updates disabled
    eCommerce Product Catalog PayPal Gateway: version: 1.4.18, author: Norbert Dreszer, Auto-updates disabled
    Feed Them Social - for Twitter feed, Youtube, Pinterest and more: version: 2.8.7, author: SlickRemix, Auto-updates disabled
    Feed Them Social Premium: version: 1.7.6, author: SlickRemix, Auto-updates disabled
    GDPR Cookie Consent: version: 1.9.0, author: WebToffee, Auto-updates disabled
    Google XML Sitemaps: version: 4.1.1, author: Auctollo, Auto-updates disabled
    impleCode Shopping Cart: version: 2.9.14, author: Norbert Dreszer, Auto-updates disabled
    NK Google Analytics: version: 1.6.2, author: Manfred Rodríguez, Auto-updates disabled
    Optimize Database after Deleting Revisions: version: 5.0, author: CAGE Web Design | Rolf van Gelder, Eindhoven, The Netherlands, Auto-updates disabled
    Page Links To: version: 3.3.4, author: Mark Jaquith, Auto-updates disabled
    Really Simple SSL: version: 3.3.5, author: Really Simple Plugins, Auto-updates disabled
    Site Kit by Google: version: 1.15.0, author: Google, Auto-updates disabled
    Smush: version: 3.6.3, author: WPMU DEV, Auto-updates disabled
    UpdraftPlus - Backup/Restore: version: 1.16.28, author: UpdraftPlus.Com, DavidAnderson, Auto-updates disabled
    W3 Total Cache: version: 0.14.4, author: BoldGrid, Auto-updates disabled
    Wordfence Assistant: version: 1.0.7, author: Wordfence, Auto-updates disabled
    Wordfence Security: version: 7.4.11, author: Wordfence, Auto-updates disabled
    WP Google Maps: version: 8.0.26, author: WP Google Maps, Auto-updates disabled
    WP Google Maps - Pro Add-on: version: 7.11.69, author: WP Google Maps, Auto-updates disabled
    WPtouch Pro: version: 4.3.35, author: WPtouch, Auto-updates disabled
    Yoast SEO: version: 14.9, author: Team Yoast, Auto-updates disabled
    
    ### wp-plugins-inactive (1) ###
    
    Accessibility by UserWay: version: 1.2, author: UserWay.org, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1650
    imagemagick_version: ImageMagick 6.7.2-7 2017-03-22 Q16 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 14 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 48 MB
    	imagick::RESOURCETYPE_MEMORY: 48 MB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.71
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.146-225.ELK.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.9 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 14400
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 256M
    php_post_max_size: 256M
    curl_version: 7.72.0 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.41-84.1
    client_version: mysqlnd 7.4.9
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home4/bimmersc/public_html/wp-content
    WP_PLUGIN_DIR: /home4/bimmersc/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### google-site-kit ###
    
    version: 1.15.0
    php_version: 7.4.9
    wp_version: 5.5.1
    reference_url: https://bimmerscan.com
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics, pagespeed-insights
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    search_console_property: http://bimmerscan.com/
    analytics_account_id: 4658••••
    analytics_property_id: UA-4658••••••
    analytics_profile_id: 8025••••
    analytics_use_snippet: no
    
    
    Renee Johnson

    (@reneesoffice)

    @bry0sb thanks so much!

    So I see that Search Console is connected, but to the http:// version of your site.

    1) Could you tell me which versions of your site are listed as properties at Search Console?

    2) Did you recently make a change to the https:// protocol for your site?

    Thread Starter bry0sb

    (@bry0sb)

    Hello, thank you for your help. Here is what is listed. As far as change to protocol no but did change to a dedicated IP via hosting company

    http://bimmerscan.com
    http://www.bimmerscan.com
    https://bimmerscan
    https://www.bimmerscan.com

    Thread Starter bry0sb

    (@bry0sb)

    I did remove a lot of bloat with sitemap in regards to tags and such reducing indexed pages which was expected

    Renee Johnson

    (@reneesoffice)

    @bry0sb really appreciate the info!

    So there is a known issue with Really Simple SSL that may be relevant here.

    In some cases, it can prevent the right version of the site from being applied when connecting Search Console.

    Could you try this workaround and share your Site Health info once more (you can just share the ### google-site-kit ### section):

    1) Temporarily deactivate Really Simple SSL
    2) Go to Settings > General and manually update your WordPress Address and Site Address to https://(if already set switch to http:// then back to https:// again).
    3) Log out and log back in to your WordPress admin (logging out may happen automatically).
    4) Reactivate Really Simple SSL

    Thread Starter bry0sb

    (@bry0sb)

    Thank you, busy thanks to google! will have time towards end of day to do and will update you. once again thank you for your time appreciate you 🙂

    Thread Starter bry0sb

    (@bry0sb)

    Okay, did it this am heres site health info -### google-site-kit ###

    version: 1.15.0
    php_version: 7.4.9
    wp_version: 5.5.1
    reference_url: https://bimmerscan.com
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics, pagespeed-insights
    required_scopes:
    openid: ✅
    https://www.googleapis.com/auth/userinfo.profile: ✅
    https://www.googleapis.com/auth/userinfo.email: ✅
    https://www.googleapis.com/auth/siteverification: ✅
    https://www.googleapis.com/auth/webmasters: ✅
    https://www.googleapis.com/auth/analytics.readonly: ✅
    search_console_property: http://bimmerscan.com/
    analytics_account_id: 4658••••
    analytics_property_id: UA-4658••••••
    analytics_profile_id: 8025••••
    analytics_use_snippet: no

    Thread Starter bry0sb

    (@bry0sb)

    Is this the issue – search_console_property: http://bimmerscan.com/

    Renee Johnson

    (@reneesoffice)

    @bry0sb thanks for reporting back! Yep that’s the problem there.

    Do you have data in Search Console for both the http:// and https:// properties?

    Thread Starter bry0sb

    (@bry0sb)

    Yes, here’s data on all properties –

    http://bimmerscan.com – 0
    http://www.bimmerscan.com – 48

    https://bimmerscan.com – 26k
    https://www.bimmerscan.com – 16

    Renee Johnson

    (@reneesoffice)

    @bry0sb thanks so much for the information.

    I’ll need to look into this further with the team, but I’ll follow up as soon as I have more information.

    Renee Johnson

    (@reneesoffice)

    @bry0sb actually could you try the following:

    1) Disconnect your Google Account from Site Kit from the top right dropdown from one of its admin pages: https://jmp.sh/9c6w4Nm

    2) Directly Sign in with Google again to re-establish the connection to Search Console (you’ll need to reconnect other services as well): https://jmp.sh/Pb7FN96

    Under Site Kit > Settings > Search Console, the property should be updated to the https:// version of the site: https://jmp.sh/LK5FUUi

    Really appreciate your attempts here. This worked on a test site, but let me know how it goes for you.

    Thread Starter bry0sb

    (@bry0sb)

    Yippee, you did it!!!! It’s working :):):), thank you so much for your help, really appreciate your time spent on this, you’re the BEST!

    Thread Starter bry0sb

    (@bry0sb)

    OOps, forgot to check the resolved box

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Search Console data is not yet available – 3mos’ is closed to new replies.