• Hi,

    Whatever I search for in my EM search bar (placed using shortcode on a regular page), it throws me to the default events slug used in settings and provides a 404 message.
    My Permalink Slug is set up as follows:
    Events: eventscal
    My event lands correctly on /eventscal/test-event-em/ when clicking on the event in the calendar view.
    Search bar throws me to /eventscal/ but I just get 404 – NOT FOUND

    I can’t find any settings to change search bar behaviour that I could assume fixes this.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    When using Events Search, Please make sure that you have properly set-up an Events Page. You can set-up this under Events > Settings > Pages > Events List/Archive

    Thread Starter ungern


    Hi Tim,

    I set that to “No page”, as I use shortcodes according to the text next to the menu:”… If you do not select an events page, to display event lists you can enable event archives or use the appropriate shortcodes…”
    This should work, right?

    Do I need to do something with the permalinks? I have published some pages for EM, and later changed slugs on those, can this lead to problems?

    My WP is setup as follows.

    EM Settings…
    Permalink Slugs – Events : em-events-calendar
    e.g. http://sustainablegastro.com/em-events-calendar/2012-olympics/

    Event List/Archives – Events page: [No Events Page]

    Pages in WP admin…
    Title: EM Events Calendar has slug
    Slug: em-events-calendar

    My WP adds the /en automatically if you navigate there with a link that is missing the /en

    • This reply was modified 4 years, 7 months ago by ungern.
    Thread Starter ungern


    After a day or two, now I’m not getting a 404, but whatever I search, it just reloads the same page. Tried setting Advance search to one of the cities I’ve entered in the events, but nothing is shown, the events page just reloads. I’m quite confused.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Search bar throws me to 404 page’ is closed to new replies.