Support » Plugin: Better Search » search accuracy

  • When I do a search for a single word, the search results are highly accurate. But if I search something that has two words (i.e. lavender water, the first few results are accurate but then, anything that has either word (i.e. lavender or water). This results in a lot of irrelevant results. Putting the search phrase in quotes makes no difference. Is there something I can do to improve my two-or-more word search results?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • I still need help with this issue. Is there any way to improve search results when searching a phrase? Thank you for any help with this.

    Plugin Author Ajay

    (@ajay)

    I just ran a search on your site and most of the results look relevant to me – having either lavender and/or water.

    Thanks for getting back to me, Ajay.

    Unfortunately, the problem is that the search picks up either word when I search for a phrase. If I am searching for a phrase item, I don’t want to get results for every single individual word in the search parameter because then the results are not accurate.

    Using a different example, if I search for “baby shower,” I don’t want to get results for either “baby” OR “shower” but rather, only for “baby shower” as a complete term.

    Putting quotations around the search words doesn’t affect the results. If I search for “lavender water” I still get results for lavender water, lavender, and water when all I want are results for only lavender water which is exactly what I am looking for. In this regard, lavender and water is not the same thing as lavender water, in the same way that baby and shower is not the same things as baby shower.

    Otherwise, the plugin works perfectly.

    • This reply was modified 1 month, 1 week ago by nyx1961.
    • This reply was modified 1 month, 1 week ago by nyx1961.

    I have exactly the same issue on my blog (culi-sandra.nl) so I deactivated the plugin now.

    i.e. when searching for ‘gerookte kip’ (smoked chicken) it comes up with search results for f.e. ‘gerookte zalm ‘ (smoked salmon) rather then prioritising the smoked chicken.

    Plugin Author Ajay

    (@ajay)

    Unfortunately that is a limitation with the matching. Have you tried turning on Boolean mode and disabling Aggressive search?

    nyx1961

    (@nyx1961)

    Thanks for getting back to me, Ajay. I have tried both but it makes no difference. Thanks anyway.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.