Support » Plugin: Cimy User Extra Fields » Seach users by custom meta field's value?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi Julyashka,

    Did you manage to work out how to do this? The fields appear across the top of the user list as there is a filter option but there is no [Filter] button.

    Plugin Author Marco Cimmino

    (@cimmo)

    You can filter already using the header’s fields.

    Hi Marco thanks for replying, when selecting an option in one of the drop down lists the data doesn’t filter. There is no submit or filter button? If selecting the drop-down option I want to filter by and then select search it doesn’t work either. Any suggestions? I am using the plugin as instructed for a multisite install and am looking at Users Extended view in the Network Dashboard.

    Thanks for your help.

    Plugin Author Marco Cimmino

    (@cimmo)

    click on Search users on top/right, it will filter

    Hi Marco, another observation is on drop down selections the description doesn’t show like in the text box field below, this is because we have to put the values in the label box instead of the value box for it to work. Is this correct?

    Thanks again.

    Sorry didn’t spot your reply. I have selected a drop down item and left all the other fields blank I want all matching records with that drop down to appear in the filtered results. However it seems to show all the records still, some with the selected dropdown items at the top and sometimes it doesn’t seem to affect the results?

    Plugin Author Marco Cimmino

    (@cimmo)

    Again:
    change the dropdown filter AND hit Search Users; changing ONLY the dropdown value won’t trigger the search.

    Thanks Marco but I have done this, I did read your comment. To confirm I have left all fields blank, selected the drop down item I want to filter by and then hit Search Users this is giving the results explained above. I have now tried it as a per blog install instead of network and get the same result.

    Plugin Author Marco Cimmino

    (@cimmo)

    Ah I saw the second screenshot now. No you are using the wrong dropdown.
    The dropdown I am talking about is in the users table’s header, NOT the form that is BELOW the list of users, that is part of the “Update selected users” and you want to use it only IF you want to UPDATE extra fields’ values on the selected users.

    Thank you Marco,

    My apologies I seem to have confused my comments by including the second screenshot and asking why the field description is missing and was I correct in that it doesn’t appear for drop downs. This was a separate question and I should have started a new topic. I was using the correct area as in screenshot 1 and using the search users button but it just doesn’t seem to be working properly for me. It is unfortunate as it’s the last bit my customer needs. Maybe it’s a plugin conflict? If so I will have to try tests on a test site with less plugins installed.

    Plugin Author Marco Cimmino

    (@cimmo)

    Unluckily seems you are not providing enough information.
    Even the first screenshot doesn’t show that you selected anything as dropdown and also at some point you speak like you are using WordPress MS and not WordPress.

    I am using the plugin as instructed for a multisite install and am looking at Users Extended view in the Network Dashboard.

    There are two ways to install the plugin on WordPress MS and you should have mentioned this at the beginning of the thread included which method you used.
    Really, the plug-in is complicated and behaves differently on installations, included if you have other plugins installed.
    Since I cannot predict which case falls yours, you MUST write everything I need to know before asking for help.

    Sorry for any confusion.

    The site is a multisite installation WP3.9
    I installed the plugin Network wide in the mu folder as in the instructions. The filter feature didn’t work for me so I moved the plugin to a per blog instead to see if it resolved the issue-it didn’t.

    I supplied the first screenshot as a reference of where I was looking and the second screenshot was in a reply with a different question which I did apologize as I should have started another topic.

    I have just tested the plugin within a different blog of the multisite installation and the filter is working correctly. I can see when I add and remove new user fields a message displays with either an error or successful. This message doesn’t appear when adding or removing fields in the blog I am having issues with. This suggests I do have a conflict somewhere and I will investigate where it is and hopefully be able to resolve it. Hopefully resolving the conflict which is stopping your messages from appearing will also resolve the filtering issues I am having.

    Thank you for taking the time to reply.

    Plugin Author Marco Cimmino

    (@cimmo)

    I need to know why then it doesn’t work on that blog. Is it the main blog or belongs to the administrator?

    Hi Marco,

    We are still investigating the issue, we don’t want to waste your time but will report back here if we find it in case it is useful.

    For reference all blogs belong to the administrator. It isn’t a usual multisite install. One customer controls all the sites, they have a multisite install to apply different themes and features to different areas of their site/sub-sites.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Seach users by custom meta field's value?’ is closed to new replies.