Support » Plugin: Braintree for WooCommerce Payment Gateway » SDK Version update

  • Resolved johnnyf03

    (@johnnyf03)


    Hi,
    We got this email from Braintree recently. Our website is running the latest version of the WooCommerce Braintree Gateway plugin. Can you please advise?

    Hello,

    Our records show that you are using a legacy SDK version that is not compatible with an upcoming update to our root SSL certificate provider for API traffic on May 1, 2020.

    If you do not update to a compatible SDK by this date, you will no longer be able to process payments through your Braintree account until you make the necessary update.
    What action is required?

    To avoid interruption to your processing, please update your SDK version on every part of your integration that is making API Calls to Braintree to the appropriate minimum version before May 1:

    Java 2.67.0
    Python 3.24.0
    Ruby 2.57.0
    PHP 3.8.0

    Note: Node and .NET Server SDKs should not be impacted by these upcoming changes.
    Where can I find more information?

    For information on how to update your SDK version, see our developer docs.

    If you are using a third-party shopping cart for your integration, we recommend reaching out to your shopping cart provider to ensure that they are using up-to-date Braintree SDKs so your processing is not interrupted.

    If you have any questions, contact us.

    The Braintree Team

    I then contacted Braintree and got the following:

    “Thanks for reaching out, happy to be of help.

    This upgrade will need to be done to the server side SDK. As you’ve noted you’re using WooCommerce the server side SDK is actually handled by them. As Braintree doesn’t make any plugins for third party Content Management Systems, The plugin you’re using would be made by a third party. I would first advise updating to the newest version of the plugin you’re using. If you’re already on the newest version I would advise reaching out to plugin developers for assistance as the SDK they’re using will not be compatible after May 1st. There is no need for you do to anything regarding your keys, the API keys do not come into play for this update.”

    Unsure how to proceed here. Many thanks

    Regards,
    John

    The page I need help with: [log in to see the link]

Viewing 16 replies (of 16 total)
  • Thread Starter johnnyf03

    (@johnnyf03)

    Plugin 2.3.9 worked for me. Activating the new plugin, WooCommerce PayPal Powered by Braintree Gateway (2.3.9), automatically deactivated the WooCommerce Braintree Gateway (2.3.0) plugin. The only small issues I had were:

    1. I had to re-activate the Braintree (Credit Card) option within Payment Settings in WooCommerce

    2. Then I had to re-enter Merchant ID, Public Key and Private Key in the Braintree (Credit Card) section

    Everything else went smoothly though. Test payment went through fine. Just waiting on a real sale to come through now. Thank you for all your help!

Viewing 16 replies (of 16 total)
  • The topic ‘SDK Version update’ is closed to new replies.