Support » Plugin: Device Mockups » Scrolling within device doesn’t work

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Justin Peacock

    (@mrdink)

    Hey @codebastler

    Have a look at https://devicemockupswp.com/scrolling/

    Main thing is to make sure you’re adding scroll=true to the shortcode.

    Are you adding this and it’s still not working?

    EDIT:

    Scratch that – just realized some updates that I was working on got pushed up by accident šŸ™

    If you need a fix right away, use 1.6.1, if not I’ll be pushing an update soon.

    EDIT 2:

    Thanks for helping with that @codebastler. I’ve put the stable tag back at 1.6.1. I’m in the process of updating the plugin and setting the version to 1.7.0 ended up pushing the work in progress. Delete the plugin and reinstall and everything should be working as expected.

    Thread Starter Codebastler

    (@codebastler)

    Hey Justin,

    yep, now it works. The scrolling is an excellent feature in a great plugin. Congrats.
    If I understood correctly then I cannot use the scrolling for mobile devices – right?
    Maybe in the future ? It would be fantastic to see how a website is responsive and adapts to small screen sizes.

    Thanks a lot for all the work and efforts that you put into this plugin.

    Cheers
    Codebastler

    Plugin Author Justin Peacock

    (@mrdink)

    @codebastler the reasoning behind no scrolling on mobile was that I found it a little intrusive when you’re scrolling down the page. For example, when you’re scrolling normally and get to the device mockup it would start scrolling the device instead of normal scrolling.

    If you want to add it to your site just add the following to your theme stylesheet

    .dm-scroll > .device > .screen {
    overflow-y: scroll;
    }

    This will make it scroll for all screen widths.

    • This reply was modified 4 years, 4 months ago by Justin Peacock. Reason: fixed css
    Thread Starter Codebastler

    (@codebastler)

    I can’t confirm that.
    Actually it works perfectly with scrolling on all sizes … :-). There is no overlapping with scrolling. Really like it the way it works.
    http://playground.codebastler.com/page/2/

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Scrolling within device doesn’t work’ is closed to new replies.