Support » Plugin: Webba Booking » scrolling problem

  • Resolved urgul

    (@urgul)


    Hello πŸ™‚
    First of all I love your plugin!
    I have a problem with scrolling. My site is built with Elementor Pro. When I load a page where Webba Booking form is, the page automatically scrolls down to the bottom. When I delete “html, body” from Scrolling container under General tab, the page does not scroll when loaded but when I click on “Zarezerwuj teraz” (Book now) it doesn’t scroll either.
    How can I do to scroll the page down when clicked on “Zarezerwuj teraz” (Book Now) but at the same time I don’t wand to scroll the whole page to bottom when loaded?
    Please help.
    My page: https://barscy.com

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author WebbaPlugins

    (@webba-agency)

    Hello,

    I was trying to open your website to check for your issue, but it returned the error ‘connection has timed out’. Maybe there is a restriction by country?

    Hello, the site works fine. I checked it via proxy (USA, Holland, France) and it worked fine, too. Maybe check it that way.

    Plugin Author WebbaPlugins

    (@webba-agency)

    Hello,

    Please, specify what shortcode are you using for Webba form?

    Hello, the shortcode is: [webba_booking service=”14″]

    Plugin Author WebbaPlugins

    (@webba-agency)

    Thank you for details, now we see the reason of this issue. We will include the fix in the next release, so if the services set in shortcode scroll won’t be triggered on load. If you need the solution ASAP, please contact us at support@webba-booking.com and we will provide a temporary solution.

    Thank you, I’ll wait for the fix πŸ™‚

    Plugin Author WebbaPlugins

    (@webba-agency)

    Hi,

    The issue has been fixed in the latest version 3.4.39, please update.

    Hi,

    I have updated but the issue still occurs. There’s still auto scroll on page load :/

    Please check out my page once again.
    The short code is: [webba_booking service=”15″]

    • This reply was modified 1 year, 4 months ago by urgul.
    • This reply was modified 1 year, 4 months ago by urgul.
    Plugin Author WebbaPlugins

    (@webba-agency)

    Hi,

    Please, clarify – are you using any cachce plugins in your WordPress?

    Hi,

    yes, I’m using WP Fastest Cache but the cache is cleared. This plugin is turned off now, the cache is cleared and the problem with autoscroll still occurs. No matter where I check my page (on different desktops, mobiles, tablets) the issue still occurs.

    Plugin Author WebbaPlugins

    (@webba-agency)

    In your case date input is not used, that’s why another scroll effect (related to time slots) is still there.

    To fix it, please edit the file

    wp-content/plugins/webba-booking-lite/frontend/js/wbk-frontend.js

    find the line 551

    jQuery(wbkl10n.scroll_container).animate({ scrollTop: jQuery('#wbk-slots-container').offset().top - wbkl10n.scroll_value }, 1000);

    and delete this line.

    • This reply was modified 1 year, 4 months ago by WebbaPlugins.

    I deleted this line and everything is working fine now πŸ™‚ Thank you.
    Will you fix this bug in the next update?

    Plugin Author WebbaPlugins

    (@webba-agency)

    >> Will you fix this bug in the next update?

    Yes, sure.

    Thank you very much! πŸ™‚

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘scrolling problem’ is closed to new replies.