Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » Scrolling for tall popups

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author danieliser

    (@danieliser)

    @blogjunkie – Sounds like you have the box for Fixed Positioning checked under Display Settings when editing the popup. Try unchecking that.

    Hope this helps.

    I saw your other responses about the fixed positioning checkbox, e.g. https://wordpress.org/support/topic/fixed-positioning-not-sticking?replies=7#post-7365803

    I might have accidentally checked it and then saved it. The popup had the fixed CSS class. I had to switch to custom size, save my pop-up, then switch back to responsive size and then the fixed positioning was disabled. Might be a bug here.

    Thanks again 🙂

    Plugin Author danieliser

    (@danieliser)

    @blogjunkie – Yea I just patched it and think I made it even more confusing, which was the opposite of my goal. Looking into how I can make it more intuitive for the future.

    Haha, UX is tough! My 2 cents: Hide the fixed positioning checkbox unless the Custom size has been chosen. And if the custom size is not chosen, don’t output position:fixed on the front end. Probably easier said than done I know. Cheers

    Plugin Author danieliser

    (@danieliser)

    Well the problem is 2 fold. Fixed works fine for responsive sizes on large screens., but no small. I am actually thinking that I will simply write a new CSS rule that is only applied to small screens that essentially disables fixed position class. So it will be fixed on desktop and not on mobile.

    Then make a note that fixed doesn’t work on small screen sizes. Sometimes its just simpler to take decision away from the user 🙂

    Good thinking 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Scrolling for tall popups’ is closed to new replies.