Support » Theme: Moesia » scroll not working on Windows phone or tablet w/ IE11

  • Resolved s4s

    (@s4s)


    Testing out an install on different devices, and I am finding that w/ Windows Phone this theme does not scroll on touch (requires arrow down or scroll bar grab to work).

    Moesia header contains the correct viewport reference, but something is breaking the touch-scroll behavior.

    I’ve looked at a few forums for ideas, such as http://stackoverflow.com/questions/15093798/ms-viewport-causing-div-not-scrolling, but can’t get it right.

    My site is http://www.bettergrades.me I’ve tested my existing content on a fresh install of Moesia, and it still doesn’t scroll, whereas activating Twenty-Fourteen, which scrolls fine.

    Thanks in advance for your help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Could you disable the custom scroller and check? It’s in Customize > General.

    Thread Starter s4s

    (@s4s)

    Easy as that! Thanks for the quick reply.

    I see why you added nicescroll, though, as the page renders much better with it on. Any thoughts on disabling it just for windows phone/tablets (IE11)?

    It could be done with some js, but I think the best course of action would be to disable it for all mobiles just to be sure. It’s not needed anyway on mobiles.

    So basically this line in functions.php:
    if ( get_theme_mod('moesia_scroller') != 1 ) {
    would become this:
    if ( (get_theme_mod('moesia_scroller') != 1) && !wp_is_mobile() ) {

    I haven’t tested this but it should work as expected. We’ll see about adding this in a future version of the theme.

    Thread Starter s4s

    (@s4s)

    Your functions.php code works fine, thanks!!

    For anyone else w/ a similar problem with Win Phone / Tablet not swiping or scrolling on a WordPress theme: Vlad resolved this by having me turn off the NiceScroll script, which he built into Customizer settings. Better, the code he posted above avoids the problem altogether, while allowing NiceScroll to work on other devices.

    I confirm the error and the solution proposed.

    I had the exact same issue and had to disable the custom scroll bar for now. I use Microsoft Flicks touchscreen with a laptop that can covert into a tablet so Vlad’s code would not work for me for some reason. The newest version of the NiceScroll script fixes this issue for IE 11 so the Moesia theme just needs to be updated with it:

    https://github.com/inuyaksa/jquery.nicescroll/commit/af737e0f2f6d0f22c66f65809b0c93e396216e51

    – IE 11 – touch support #418
    – Scrollbar displayed but not scrollable on IE11 with Windows 8 touch
    device #407

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘scroll not working on Windows phone or tablet w/ IE11’ is closed to new replies.