Support » Plugin: A-Z Listing » Scroll dont works

  • agbaly

    (@agbaly)


    I have two pages with two diferent shortcodes that were working ok several days ago. But now, I dont know why I have a problem: The link on each letter seems to be ok, it’s well constructed, but it dont scrolls down when I click it.
    Could you help me?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Daniel Llewellyn

    (@diddledan)

    This is not a problem with the A-Z Listing plugin. Something else on your site is intercepting the browser’s ability to scroll to the correct place on the page.

    The scrolling feature is entirely browser-native with no custom code to implement it in A-Z Listing. It relies on the browser to correctly implement scrolling on #section-anchors, which is a standardised concept. If it doesn’t work, as in your site, then some javascript you have is likely intercepting the clicks or the navigation attempt and preventing the browser from performing its default behaviour.

    agbaly

    (@agbaly)

    I understand, but I tried to put an anchor in the same page and it works fine. Please try this link: https://www.wondersoundtrack.com/indice-bandas-sonoras/#prueba it goes to a text block at the end of the page.
    And the arrow yo scroll up of the theme works ok too.
    In the other side, if I try the letters links it doesn’t work. Could you give me a clue of whats the problem? Never happened this before?
    I disactivated the cache too.
    Thank you

    Plugin Author Daniel Llewellyn

    (@diddledan)

    It looks like you have the A-Z Listing twice on the same page, but only one instance is visible. The visible instance is the second copy so the browser might be trying to navigate to the first, hidden, instance and so doesn’t scroll to anywhere because it’s invisible.

    agbaly

    (@agbaly)

    Thank you very much, it’s fixed!
    I was totally lost with this. I made two sections, one only visible for mobile devices and the other one for computers and I never thought it was a mistake.
    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.